Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My system (Dell Inspiron 8100) uses Nvidia NV11 GeForce2 Go at 1600x1200. All is working, save I cannot get any hardware acceleration, making video playback and animation unbearably slow and jerky. In "Additional Drivers" I show TWO instances of NVIDIA binary Xorg driver, kernel module and VDPAU binary. Neither is "activated" and when I try to activate I get "SystemError: E:Unable to correct problems, you have held broken packages"

I have no clue what package might have been "held" as as far as I know I never refused to allow any upgrades. I would like to simply remove BOTH instances of the binary, but nothing I have tried works.

Doing an lshw scan for nvidia hardware reports the driver=nouveau.

I tried to do the update to the nvidia-current, and remove nouveau, but that failed, leaving me running in 800x600 degraded mode. The Nvidia-Settings app reported no Nvidia driver installed after the update. I tried several attempts to force it, by editing xorg.confg and other hacks with no luck.

I think my problems stem from the broken binary drivers inhabiting the additional drivers app, and if I can get them out, the nvidia-current might install correctly. But despite many attempts, I am just stuck.

Help Please? I am unable to proceed at this point, having exhausted all my own expertise. The system works fairly well, save the lack of acceleration. I just need to get over that little bump and I would be one happy camper. Any clue would be most appreciated.

Thanks, Nathan

share|improve this question
    
What do the errors say? Run: sudo apt-get update; sudo apt-get upgrade –  wojox May 29 '12 at 16:21
    
What errors? I listed the systemerror reported above. If apt-get upgrade would have fixed anything I wouldn't be here. Done that. It downloads nvidia-current and seems to install, but as I described it fails and throws me into degraded mode. I have no clue why, other than the oddity of two binaries. –  Nathan May 29 '12 at 16:28
    
Really you have broken packages and apt-get doesn't show anything? –  wojox May 29 '12 at 16:30
    
Not that I can see. Maybe I'm missing something, but it just seems to do it's thing without mentioning any issues with the duplicated drivers, or anything obviously connected to them. –  Nathan May 29 '12 at 16:35
1  
@Nathan: you listed errors from the GUI package manager, never mentioned running the commandlines that were suggested, and now you're getting an attitude; this isn't a good way to get help from volunteers. But if it helps, I've always gotten a failure trying to install the newer version driver of the two. –  Marty Fried May 29 '12 at 16:40

1 Answer 1

The OP found a solution. Reformatted excerpt:

The business of the bogus "Additional Drivers" entries was a red herring. Turns out the problem was color depth. This old and wimpy machine simply cannot handle the default color depth that 12.04 assigns.

Installing a basic xorg.conf setting color depth to 16, down from the default of 32, made a huge, huge difference.

There is still room for improvement, but I do not expect miracles from such very old hardware. It now plays Youtube videos, in the browser window just fine. Of course full-screen is too much, but that is to be expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.