Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Intel Hardware Raid on the motherboard.

I have 10 2 TB HDD that I've configured as RAID 1+0 to be one big 8 TB HDD.

Now I'm trying to install ubuntu 12.04 on it.

After installing with default desktop installation disk I get a blank screen with a cursor flashing.

If I try the alternate guided partitioning option I get error: out of disk. and the grub> prompt.

If I boot with the rescue disk or such like I can drop into a shell and view the disk. Everything also installs without an issue.

Don't know what to do...

share|improve this question
up vote 1 down vote accepted

Try the alternate text-based installer which you can find here:

You may need to give yourself a separate /boot partition near the beginning of the hard drive array when you are choosing the partitioning. Your BIOS may have a limit on how large of a disk it can initialize the boot from.

share|improve this answer
Tried that combination, now I get Unknown filesystem when grub tries to boot – Michael Wiles May 30 '12 at 7:45
What was is your partition scheme (sizes, filesystem, location)? An example scheme might be: | boot ext4 10 GB | root ext4 7.98 TB | swap 10 GB | (just as an example) – DavidW May 31 '12 at 19:54
thanks for the help, turns out a guided install from the alternate installer worked fine. – Michael Wiles Jun 4 '12 at 11:10
I'm glad to help. Please accept the answer if you are satisfied. – DavidW Jun 5 '12 at 15:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.