Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed wordpress on my ubuntu 10.10 desktop edition and I am trying to install plugin from the browser (I know I can drop it to the wp-content/plugin but I want to do it via the web browser using FTP) I get this screen when I am trying to set auto update or install a plugin from web browser.

alt text

I provide the hostname and Username and password the ones that I use to login to wordpress. I get the error

Username/password Incorrect and cannot connect to

I think i'll have to grant a user with ftp password but I dont know how. I have already installed vsftp but when I try "ftp" I get -

$ ftp
Connected to
220 (vsFTPd 2.3.0)
Name ( root
331 Please specify the password.
530 Login incorrect.
Login failed.

Wordpress is running locally on my Ubuntu Desktop.

share|improve this question
up vote 13 down vote accepted

Well your Wordpress login and your FTP login are two different things. I have see that you use vsFTPd, so one easy thing that you can do it this :

Edit the vsFTPd configuration file :

gksu gedit /etc/vsftpd.conf

Add this at the end :


Restart your vsFTPd server :

sudo /etc/init.d/vsftpd restart

Now you should be able to connect to your FTP using your Ubuntu login.

share|improve this answer
and how can I grant a user (wordpress user) access to FTP who can use FTP over the network – Gaurav Butola Nov 22 '10 at 7:55
I would also not login as root, but create a dummy user, make him part of your www-data group and use it to push updates/install – csgeek Nov 22 '10 at 15:14
I had this same issue and just wanted to add for any others that are going through this that you need to use '' and not 'localhost'. Or at least I did. Also had to use FTP not FTPS. – Jay Jan 8 '11 at 8:31
-1 Even though it's listed as best answer, it lacks the information that write_enable is commented out by default. If you do not uncomment, your solution still doesn't work. – Jakke Aug 22 '14 at 3:12

If you are using the default file the problem I had was not seeing enable write access. That resolved my problems.

share|improve this answer
The same issue here, write_enable is commented out by default. Thanks for the tip. It's nowhere mentioned here, but I also changed the home directory for the wordpress ftp user to /var/www/html (or whatever the path to the site is). I'm not sure if this is actually needed. – Jakke Aug 22 '14 at 3:11

I had the same issue.

When I created my Ubuntu server I installed a wordpress site and everytime I wanted to update a plugin I needed ftp access which was really annoying. I new I could jsut add the ftp details in the config for wordpress but I was Like NAH! so It turned out that wordpress cant write files to the wp-content directory because apache doesn't have permission to edit the directory so this is how I fixed it.

Copy group file to groups in the same directory

sudo cp /etc/group /etc/groups

Then give Recursive Permission to apache

sudo chown -R www-data:root /var/www

Thats it.

Another way of doing it is by editing apache envvars

sudo nano /etc/apache2/envvars

Edit the lines where it says

export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data

And replace www-data with your username for ubuntu


now restart apache

sudo service apache2 restart

and then make sure your account has permissions to the directory

sudo chown -R USERNAME:USERNAME /var/www

If this doesnt work for you then simply reply.

share|improve this answer

To configure vsftpd, open vsftpd.conf in /etc and copy paste the following into your vsftpd.conf

ftpd_banner=Welcome to my FTP server.

You should create a new directory inside /srv in the name ftp or what ever name you prefer.If you prefer another name then you should change the line anon_root=/srv/ftp to anon_root=/srv/toyourfoldername Now place all your files inside the folder /srv/ftp

To test your settings in localhost type:
If you have any problems let me know.

To start/stop/restart vsftpd:

sudo service vsftpd start
sudo service vsftpd stop
sudo service vsftpd restart
share|improve this answer
+1 for sudo service vsftpd .... – solgar Dec 18 '15 at 19:02

This worked for me:

Add this file to wp-config.php:

if(is_admin()) {
    add_filter('filesystem_method', create_function('$a', 'return "direct";' ));
    define( 'FS_CHMOD_DIR', 0751 );

for more

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.