Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an older PS1 console with a couple of games I bought some years ago. On my pc, I'm using PCSX Reloaded - the best PS1 emulators for Linux I found so far.

But I'm having a little issue on Ubuntu 12.04 Precise. I'm using Unity 3D and I'm trying to run some of my original PS1 games on PCSX Reloaded. Everything works nicely, except for fullscreen. I toggle fullscreen and specify maximum resolution for my monitor, but on fullscreen mode, both left and top unity bars aren't getting hidden.

I tried changing between other graphic modes like Gnome Classic and Gnome Classic w/o Effects. On both, PCSX shows bars in fullscreen mode, so it isn't an Unity-specific issue, but an emulator problem.

It's a bit annoying play games this way, so basically I'm running games on window mode for now. I'm using default OpenGL graphic plugin on this emulator. I tried changing to X11 graphic plugin and fullscreen worked, but graphics on X11 plugin aren't as good as OpenGL one.

Anyone know a way to get fullscreen working on PCSX using OpenGL plugin? Or maybe another graphic plugin w/ OpenGL support.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

If you installed though synaptic, you should have a second GPU plugin pre-installed (XVideo Driver 1.1.17).

Switch to it in the configure menu. Fixed it in my case (ubuntu 12.04 64bit)

share|improve this answer

This is a commpatibility issue. You can try by changing the graphic plug in in pcsx

share|improve this answer
    
I think that too. I tried changing between other graphic modes like Gnome Classic and Gnome Classic w/o Effects. On both, PCSX shows bars in fullscreen mode. I'll try that later. –  Leonardo Montenegro May 29 '12 at 17:36

this sounds a bit complicated, i have a note book and run just fine, i set up full screen by changing the resolution on settings, the only thing you have to understand is that the psone resolution has to be kept as the games where made for that resolution. my unity launcher hide perfectly when i run the game. try changing resolution, without stretching the image (keeping original psone) and run the bios right after, try till yours work. wish you luck!!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.