Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed 12.04, but I had the same problem in 11.10. When I watch a video, VLC suppresses the monitor being turned off. In older (pre-Unity) Ubuntu versions, this would only be in effect while the video was playing. Now VLC is disabling the turning off of the monitor regardless of if it is playing or not.

Is there a way to fix this? Or a less quirky shell? Or a video player that doesn't exhibit this behaviour?

share|improve this question

1 Answer 1

1.

check for,

Tools => Preferences => Show All => Video => Disable screensaver

enter image description here

if you want to enable screen saver uncheck it.

Tools => Preferences => Show All => Advanced => Inhibit the power management daemon during playback

enter image description here uncheck this to make monitor turn of while playing in vlc.

2.

try this script for respective options

#!/bin/bash

xset -dpms #do not allow turn off
xset s off #do not allow screen saver

xset dpms #Allow turn off if not work then try -dpms
xset s on #Allow screen saver
exit
share|improve this answer
    
I already had those settings, but thanks dawg. –  user973810 May 29 '12 at 23:22
    
@user973810 what do you mean ? you have both the settings checked or unchecked? BTW try script given it always works. –  virpara May 30 '12 at 2:08
    
Those 2 settings were already checked, and the script didn't fix a thing. –  user973810 May 31 '12 at 3:08
    
@user973810 uncheck both settings. Close VLC. then play video. I have already tested. –  virpara May 31 '12 at 12:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.