Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 12.04 x64 (server) on my ESXi 5.0U1 server and it's mostly working fine except when I try to turn off the system using the halt command (/sbin/halt) it says "Powering off..." but the virtual machine never actually turns off.

If I use the VMware tools to shutdown the host it does turn off, but /sbin/halt worked in every other Ubuntu version and also works in Debian so it should work now...

Anybody have any suggestions?

EDIT: After further testing, "halt -p", "shutdown -h now", and "poweroff" all correctly power-off the machine but "halt" (without parameters) does not. However, in Ubuntu 10.04, "halt" did power-off the machine. Is this simply a difference between the two versions of Ubuntu?

share|improve this question
add comment

2 Answers

The following command works for me

shutdown -h now
share|improve this answer
add comment

I've experienced the same problem on Ubuntu Server 12.04 every command except halt works fine. I have also tried this: Shutdown does not power off computer but without any effect. So the best thing is use different command or just create a simple script with http://paste.ubuntu.com/1044866/

and save it as ex. powerdown in /usr/local/bin

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.