Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have mounted a folder from my NAS (Ubuntu Server 10.4, Samba) on my workstation (Ubuntu 11.4 CIFS) and everything works fine, except MS Office 2010 can't save to that folder. I see Word creates a temporary file and then it asks me for a new file name. Excel and Powerpoint do the same. There are not strange characters in the filename.

share|improve this question

I'm afraid this is only a partial answer, but I have found mounting the same shares over gvfs works. Using gigolo to automount makes this manageable.

I have experiment with just about every cifs setting, but can't find anything to help. I'd love to have a full answer to the same question.

share|improve this answer
Thanks for the answer, it seems there really isn't a way to mount cifs shares properly. I'm mounting the same directory via sshfs now and it works. – Jure1873 Oct 21 '12 at 13:08

I have managed to make this work on my Readynas duo v2 with the following settings. My guess is that this will work on most systems with a little adaptation.

in /etc/frontview/smb.conf.CIFSFS I added:

unix extensions = 1

in /etc/frontview/Shares.conf I have the following (I don't know which bits, if any are important)

path = /c/leo_share
force create mode = 0666
create mask = 0666
force directory mode = 0777
directory mask = 0777
admin users = "admin","Administrator"
write list = "Leo","admin","Administrator"
valid users = "Leo","admin","Administrator","nobody"
vfs objects = recycle
recycle:versions = 1
recycle:repository = Recycle Bin
recycle:subdir_mode = 777
recycle:keeptree = 1
recycle:directory_mode = 777

I mount the share using:

//192.168.1.xx/leo_share <path> cifs credentials=<path>,file_mode=0700,dir_mode=0700,uid=1000,gid=100 0 0
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.