Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log into Citrix from my laptop with 10.04, and click on the windows RDP app to launch, and select full screen, it only fills in between the gnome panels, and adds scroll bars. This does not work well at all. And I'd love to get a fix (as a work around I tell citrix to use a full-screen session, not seamless, and this works as expected, but has it's own usability problems)

Logging in on my desktop with Ubuntu 10.04, full screen works correctly. The only difference between the computers is the laptop has intel graphics and the desktop nvidia.

Thanks!

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

Have you tried to use rdesktop directly?. It's the real program doing the talk to Citrix.

You can try it from the command line:

$ rdesktop -f computer-name-or-ip

Where -f is the switch for full screen. If it works, then there are other frontends for rdesktop in the repos, you could try them to see if some one behaves correctly, just search for rdp in the Software Centre. If it doesn't maybe the nxClient from NoMachine could work, it's a free (as beer) but closed source product.

I don't know any other implementation of rpd that works on linux. But maybe there is some nice java or flash client out there.

share|improve this answer

How do you launch citrix? Do you launch through a ica file or through a web frontend? If it's the later you should be able to go into settings in the web ui and change the window settings.

Try changing it to a percentage of the screen and put 99% or something.

Try Ctrl+Alt+Break for changing between windowed and full screen. It's hotkeys for the windows version. I've never used em and can't test it right now, but it's worth a try.

share|improve this answer