Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd like to use the Compiz "Scale Window Title Filter" on 12.04.

I've already read another answer which just said to install compiz-plugins-extra and enable "Scale Window Title Filter" in the ccsm. I've done this, but when entering scale mode (<super>+w or <shift>+<alt>+<up>) nothing happens when I type.

I have tried restarting unity, logging out and even rebooting, but this behaviour remains the same.

Am I missing something? How do I enable it? Has anyone got it working correctly on 12.04?

share|improve this question

5 Answers 5

Enabling the Scale Window Title Compiz filter in Unity 12.04

1. What does the scale window title filter do?

  • The Super+W shortcut shows you miniature (scaled) versions of all the windows in your current workspace, and you can click on any one of them to switch to it.

    enter image description here

  • The somewhat oddly named scale window title filter allows you to type and filter windows out in the scaled view based on the titles of the windows. It's useful to narrow down things when you have many applications/windows open.

2. How do I install it?

  • You will need the Compiz Config Settings Manager (ccsm) and some extra Compiz plugins. Open up the Software Center, search for (a) "compizconfig" and (b) "compiz-plugins-extra" and install those packages (see screenshots below). (Those who prefer apt-get can install the packages compizconfig-settings-manager and compiz-plugins-extra instead)

    enter image description here enter image description here

  • Close the Software Center.


3. How do I activate it?

Statutory Warning: Compiz Config Settings Manager is an advanced tool and one tiny mistake, typo or an accidental click of the mouse can leave your desktop unusable, requiring time and effort to fix it. Please be very careful and follow instructions...thanks. If you mess up, please see this answer on how to fix things.

  • CCSM can become unstable and crash if you try changing settings with multiple windows open. I highly recommend you close all running applications before trying this.

  • Start CCSM from the Dash by typing "compiz" and clicking on its icon:

    enter image description here

  • Type "title" in CCSM's Filter box to see the "Scale Window Title Filter" appear on the right side (see screenshot below). Click on the checkbox next to it, and it will be highlighted orange. You may get a popup asking to also enable the "Text" filter -- click OK if that happens. Close CCSM.

    enter image description here


4. How do I use the scale window title functionality?

  • In this example, we'll use a workspace with six windows: two Terminals, one Firefox, one Writer, one Software Center and one System Settings.

  • Press Super+W to bring up the scaled windows:

    enter image description here

  • Typing one letter s reduces the windows shown from six to the four that have s in their titles: Software Center, System Settings and the two terminals (because my machine has "precise" in its name):

    enter image description here

  • Typing something unique to the title of an application -- my username izx -- reduces the windows to the two terminals:

    enter image description here

  • Similarly, wri for Writer shows you just that window, nearly maximized.

    enter image description here

  • Click on any window at any point to bring it to the front.

  • As you Backspace out while typing, the view is adjusted to match.
  • You can clear the filter and go back to the unfiltered full view by pressing Esc at any time.

5. What settings can I customize for this filter?

  • Start CCSM again (be careful!), filter for "title" and click on the "Scale Window Title Filter" to bring up its settings. Exce

  • Under "Behaviour" (best left untouched) you can set the:

    • Filter timeout in seconds (if you haven't typed in this much time, text will be cleared and you will go back to the unfiltered scaled view)
    • Case-sensitivity of the filter
    • Whether the typed text is shown on the screen

    enter image description here

  • Under "Appearance", you can adjust:

    • Whether the filter text is bolded or not
    • The font size (larger may help on a high-resolution display)
    • The title border size (the border around the filtered text)
    • The font color (and opacity)
    • The background/border color (and opacity)

    enter image description here

6. I don't like it! How do I disable it?

  • Start CCSM, filter with "title" and simply uncheck the "Scale Window Title filter" checkbox. Again, this is best done with no other applications open.

Sources: Compiz Wiki

share|improve this answer
1  
If you run ccsm from the terminal, please wait for it to finish initialization before you do anything in it! –  izx Jun 11 '12 at 11:26

This plugin requires the text plugin in order to draw text on screen. Be sure to have this plugin enabled too.

share|improve this answer
    
I'm afraid that text plugin is already enabled. ccsm asks if I want to enable each of the plugins it requires when I enable the "scale window title filter" plugin. –  grifferz May 29 '12 at 12:51

You should also have installed compiz-plugins-main, that is not installed by default nor for dependency. Anyway, i've the following packages installed, and works for me:

enter image description here

share|improve this answer
    
I see. I do already have this installed - I've edited my question to include a list of the compiz-related packages I have installed. So, you have the scale filter plugin working on 12.04 under the Unity desktop? As in you hit <super>+<w> to go into scale mode then you can type to filter the windows shown? If so then I guess there is some bug affecting just my configuration. –  grifferz Jun 5 '12 at 0:23
    
yes, it works here on x86_64, 12.04, unity3d. have you tried with a clean user? ubuntuone.com/4nG6WkjFcWpa8imAKc3UZp –  Lorem Jun 5 '12 at 1:24
up vote 1 down vote accepted

I now have this working and I am answering it myself because no other answer exactly got it.

It turns out that I had been running ccsm from a shell. I instead launched it from the dash and then the plugins I selected were enabled without me having to log out or anything. Scale Window Title Filter now works.

Thanks to Lorem for sending me in the right direction, as by trying it with a new user account I saw that it would work and it was just something wrong with my user's configuration. I don't know why running ccsm from a shell is wrong or where those settings go, but clearly it is not to the right place.

share|improve this answer
1  
How you runccsm has nothing to do with this. It works fine for me running from a shell. Probably something to do with your user configuration? –  izx Jun 10 '12 at 5:22

Scale Window Title Filter is part of the compiz-plugins-extra package.

Install this package:

sudo apt-get install compiz-plugins-extra

And then Scale Window Title Filter will show up as a plugin in CompizConfig Settings Manager.

In CCSM you can set the keyboard shortcut for Scale to be a toggle ("Key bindings toggle Scale mode" under Scale settings), or you can set Scale to be activated by for example dragging the mouse to a screen corner, and use that instead.

share|improve this answer
    
OP said he tried this already... –  izx Jun 4 '12 at 13:44
    
As you can see from my compiz config, this plugin is already installed and enabled. Does anyone have this plugin actually working on 12.04? It's pretty simple to test even if you don't intend to to use it. –  grifferz Jun 4 '12 at 16:45
    
a long shot, but, there is another bug in scale plugin with showing apps from all workspaces and only fixed via ppa, launchpad.net/~bsantos/+archive/ppa . maybe you can try it –  duffydack Jun 4 '12 at 21:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.