Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am encountering this problem:

I type sudo apt-get install <package>, and hit Enter. apt-get starts resolving dependencies and downloading/installing packages. While it is running, I want to enter another command in the same terminal, so I type it (let's say echo done).

The problem is, I type echo done and Enter, but when apt-get finishes, the echo done is not executed. The shell comes back to me with a prompt, and there is nothing in its input buffer. So, bash seems to ignore my input while apt-get is running. This "ignoring" doesn't seem to happen with any other command.

I would like to figure out why this is happening, and if I can change the behaviour somehow.

share|improve this question
I recommend reporting this as a bug. – Eliah Kagan May 29 '12 at 4:13
FWIW, I tried it right after doing sudo apt-get update, and it worked as expected. – Marty Fried May 29 '12 at 4:26
@MartyFried, just to be sure: once apt-get finishes, I can type commands and everything works normally. I can't type commands while apt-get is running though. I am using Ubuntu 12.04. I guess I should report this as a bug. – user536048 May 29 '12 at 4:36
I understand. I entered the command quickly while it was still running, and when it finished several seconds later, it echoed the command and the result. But I just did the update, and didn't actually install anything. – Marty Fried May 29 '12 at 4:47
Did you add the -y switch OR confirm installation before entering the other command? Otherwise your input just goes to the prompt which comes up when trying to install larger packages. – izx May 29 '12 at 5:30

You might want to try to execute any command by adding in the very end of the command the &., e.g.: dolphin &. This way the process will run on the background and the terminal will be free to operate on.

Update: it seems, however, that interactive processes, like sudo apt-get install <package> that expect a user input (for example sudo's password) just wait in the background. They can be re-reached with the command fg.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.