Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know that my touchpad is capable of it. I can enable glitch-free two-finger scrolling by running this script:

#! /bin/sh

synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1
synclient EmulateTwoFingerMinW=10
synclient EmulateTwoFingerMinZ=48

However, in the "Mouse" preferences GUI, the "two-finger scrolling" option is greyed out. It worked fine on my old laptop.

Here is the output of sudo lshw -sanitize, if it makes a difference.

share|improve this question
    
What version of Ubuntu are you running? And what laptop is this? –  Mussnoon Nov 23 '10 at 13:18
    
It's Ubuntu 10.10 on a Dell Studio XPS 16 (but I've had this problem since at least 10.04). You can see the details of my hardware in the lshw output that I posted. –  Matthew Nov 23 '10 at 16:00
    
Please use the synaptics tag instead of synaptic to put your question in the list of Synaptics (touchpad) questions, rather than with the Synaptic Package Manager questions. (Oh how I long to have 200 rep so I can just do this housekeeping myself.) –  dgw Dec 16 '10 at 2:06
    
@Voyagerfan5761: Done. Good call, I was wondering why there were so many questions about touchpads. –  Matthew Dec 16 '10 at 5:43
    
There are enough touchpad questions. I asked one myself. They can be finicky little buggers. Glad you found my suggestion useful. :) –  dgw Dec 16 '10 at 5:56

3 Answers 3

up vote 2 down vote accepted

This is my understanding of it. Ubuntu doesn't have support for the Synaptics touchpad officially out of the box, so what that script does is it emulates the multi-touch. I think. I don't know for sure, but that is my understanding of that. (I myself have a Synapatics trackpad on my Asus Eee PC, so I've spent a far amount of time working on this.)

share|improve this answer

Press Alt+F2, write gconf-editor, it will open gconf-editor, go to destkop, gnome, peripherals, touchpad and type 2 for the variable "scroll_method". The option will stay grayed but two finger scroll will be enable. Works for me.

share|improve this answer
    
I'm afraid this doesn't work for me. It's ok though--I've got two-finger scrolling working, I just want to know why I couldn't do it from the GUI. –  Matthew Nov 24 '10 at 20:05

I don't have a laptop to test it with, but I recently stumbled upon this site: http://stuffivelearned.org/doku.php?id=os:linux:general:synapticstouchtricks

Perhaps this helps you.

share|improve this answer
    
Great link, thanks. –  Mussnoon Nov 23 '10 at 13:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.