Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the most frustrating bug I've ever ran into on Ubuntu. This was not a problem with 11.10 or even 12.04 betas. When I boot up the wireless is always blocked, whether by a hardware switch (Fn-F2 on my laptop) or by the option in Ubuntu. Occasionally I fool around with fn-f2 in different scenarios and I can get it working. However, any time afterwards when I reboot the problem comes back.

I've looked into many of the other answers and tried the solutions (rfkill, rmmod, etc) to no avail.

share|improve this question
    
Did you try 'rfkill unblock all'? –  To Do May 28 '12 at 21:04
    
Yep. There's no output and it's still disabled after. –  Andrew May 28 '12 at 21:32
    
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro Jul 12 '12 at 15:14
add comment

2 Answers

You said you've tried rfkill, but this worked for me,

http://www.dkvermalinux.in/2012/05/ubuntu-1204-lts-wifi-problem-hardware.html

share|improve this answer
    
This seems to have gotten me half way there, it's no longer being reported as soft blocked. However, I then had to completely disable networking and re-enable in order to get Wireless working again. –  Andy E May 30 '12 at 11:27
add comment

After trying all the suggestions I have seen here, I was about to give up but I happened to be installing a wifi dongle on my raspberry pi (a single board computer running linux). The instructions I found for that machine was to add the following lines to /etc/network/interfaces file. After saving the file and reboot, my Ubuntu machine now was turning on the wifi and all is good.

after the existing lines:

auto lo
iface lo inet loopback

add this:

auto wlan0
allow-hotplug wlan0
iface wlan inet dhcp
   wpa-ssid "yourSSID"
   wpa-psk  "yourpassphrase"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.