Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a huge problem with my android samsung galaxy tab 7".

Whenever I try to connect it to my computer, instead of showing normally in my adb devices, the name of the device is : ????? and it status is online or device.

I really don't know what is the problem, any help would be really appreciated. If you need more info, I would be happy to give it.

Ubuntu : 11.04

Device : Samsung galaxy tab 7"

Android version : 3.2 HoneyComb

I also added the rules in /etc/udev/rules.d/51-android.rules

share|improve this question

3 Answers 3

The '?' means that it can't determine the serial number , but adb may still work. The first thing you should try if it doesn't is to try a different USB cable/and socket. There are enough anecdotes involving Samsung devices to suggest that this is the problem.

You probably don't have adb over tcp/ip enabled but if you do turn that off.

If it says "no permissions", then that usually means a udev problem. If it works when you run adb as root then it is a problem with your udev rules: sudo /path/to/adb devices. One thing to watch out for with udev is that your computer needs to be rebooted for your changes to be recognised.

share|improve this answer

Sometimes even with 51-android.rules, it may not work. I have the same problem, but adb sees my phone just fine, except for that. I run a program called Qtadb, and everything's there, but the bootloader, and serial number. I don't have to have the debugging notification running at all, just plug it in, and it works! I can do everything with adb that I want. When I run adb from a terminal, it recognizes that it's a device, but I get the ?????.... But it hasn't affected my work, it's just a nuisance.

What I'm saying, if it's working regardless, don't worry.

share|improve this answer

Try this:

sudo adb kill-server
sudo adb start-server
adb devices

Please note that either you have adb on your path or you go to the platform-tools directory and then run these commands.

share|improve this answer
    
adb doesn't require sudo and shouldn't be used this way. –  user827992 Aug 11 '12 at 23:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.