Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Under some circumstances, Shotwell shows no photo thumbnails while importing. I was trying to download some pictures from my camera (Canon EOS 400D) with Shotwell and the program didn't show any preview for the pictures before downloading them (it just shows a "forbidden" snapshot). After importing them everything seems fine.

I've found this bug report but no solution is given for now. It seems there could be a solution for EOS cameras, according to the last comment. This guy links to a patch, but it's not downloadable. Any ideas of where to obtain a deb package of this patch or of any other solution?

share|improve this question

closed as off topic by Jorge Castro, Nitin Venkatesh, RobotHumans, izx, Eliah Kagan Aug 14 '12 at 21:37

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. – Nitin Venkatesh Aug 14 '12 at 7:07

If you click on the "Patch" link you can then save the patch as a .diff file and apply it against trunk.

You can get a copy of gphoto's working trunk with

svn co gphoto

Applying the patch is something akin to this command:

patch -p1 < gphoto.diff

(Note: I haven't actually tried this, but I believe it will work.)

share|improve this answer

Sorry for the late answer. Since I didn't know how to use the svn trunks I simply downloaded libgphoto2 from the official sourceforge page. I changed manually the lines in library.c, just exactly as in the patch. However, after compiling it (doing the typical "configure", "make", "sudo checkinstall", and having downloaded lsusb-dev from repositories) it seems Ubuntu doesn't do anything when I connect the camera, so that I can't download the pictures. In any case, if I write lsusb in the terminal I get:

Bus 001 Device 004: ID 04a9:3110 Canon, Inc. EOS Digital Rebel XTi

So strictly speaking the OS detects the camera, but it does nothing.

Since I was having this problem, I came with another solution. It's not as elegant as compiling it, but it worked. The idea is just to download the official Ubuntu 11.10 libgphoto2 package from here . Then in a terminal you just type:

sudo dpkg -i libgphoto2-2_2.4.11-3_(architecture).deb  

Now it is possible to see all the pics, although it is done in the "old way" (this version doesn't have the "EOS fast directory" enabled).

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.