Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

No sound when installed in VirtualBox. When I boot from the live CD in Windows, sound works fine on my speakers. When in boot the live CD in VirtualBox it does not see my speakers. In sound properties only digital output built in S/PDIF and headphones!

I've done the pavcontrol - alsamixer - all settings are OK. I've tried both 32/64 versions of Ubuntu. Running current version VirtualBox. System: Windows 7 64 - i5.

What am I overlooking?

share|improve this question
    
Have you been able to resolve your problem? –  irrational John Jun 3 '12 at 3:27
add comment

4 Answers 4

Is your audio setting for your Ubuntu guest virtual machine set to ICH AC97?

ICH AC97 is the only VirtualBox VM audio setting which allows me to get sound when running Ubuntu as a guest and either Windows or OS X (10.6.8) as the host.

In particular, if a VM's audio setting is Intel HD Audio then sound does not work in an Ubuntu 12.04 desktop guest.

On the other hand, sound will only work for a Windows 7 (64-bit) guest when the audio setting is Intel HD Audio. This can be rather annoying when you are working with a VM which dual boots either Ubuntu or Windows 7 as the guest OS.

I have never investigated this further to find out why it works this way or if there is a way to work around it. If you happen to find one, please let us know about it.

Note: You will have to "power off" your VM to change its audio setting.

share|improve this answer
add comment

For a windows guest, Ubuntu host system, set the VM to use ALSA on the host and the VM soundcard to Intel HD.

share|improve this answer
add comment

Try installing the VirtualBox Guest Additions by going to Devices> Install Guest Additions. This usually fixes problems for Virtual Machines like audio and adds more features to the VM.

enter image description here

share|improve this answer
1  
did that works OK. still NO sound. –  john crisp May 28 '12 at 20:03
    
You may need to completely shut down the guest and start it up again after doing this. That fixed it for me (while a simple reboot of the guest did not). –  ashes999 Jul 8 at 16:24
add comment

Host system: Solaris 11.1, VirtualBox guests: ubuntu 12.04, Windows 7, linux mint

  • Host Audio driver: for ubuntu 11.04: OSS, for ubuntu 12.04: OSS
  • Audio Controller: for ubuntu 11.04: Intel HD Audio, for ubuntu 12.04: ICH AC97
  • Different audio controllers for different guests are not a problem, because under VB adjustments are individual for each machine.
  • For me, sounds (including event sounds (beep etc.)) worked perfectly again, after switching to GNOME classic(No effects), but the event sounds are missing under ubuntu and GNOME classic.
  • Works fine with OSS on the host, ALSA not required; applies to ALL guests.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.