Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having an issue with a shared library called libsdl. What I'm trying to do actually is to start up a game engine called GCCG (Generic Collectible Card Game). All the necessary packages were installed for the engine, however when I run the command ./Mtg it gives me the following:

./ccg_client: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

From the error message, it seems clear that the libSDL libraries are either not installed or they cannot be accessed/are miss-located. After checking my packages with dpkg --get-selections | grep libsdl I found out that all the libSDL packages are installed... so just to make sure, I used sudo apt-get purge on all of the libSDL packages and made a clean install on all of the libSDL packages, however, the result is still the same.

Furthermore, when I use apt-file search libSDL-1.2.so.0, to locate the so-called "missing libraries", I get this as a result:

libsdl1.2debian: /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0

libsdl1.2debian: /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0.11.3

So, as I figure it, they are there... but they are not shared?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Is this a 32 bits or a 64 bits binary ? ( you can check with file ./Mtg ).

If this is a 32 bits binary, then you need the 32 bits version of libSDL, as you seems to be running x86_64.

share|improve this answer
    
Indeed. Thank you so much... I checked the game's client with the file [client_file] command and indeed, it was a 32bit binary. So I installed all the libSDL 32bit equivalent libs and it worked out just great. Thank you again for the tip... now I know about the FILE command... I'm new to Linux. =)> –  Kallestofeles May 28 '12 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.