Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to import digital photos in Ubuntu 12.04.

When I plug in my camera (Canon EOS Rebel Tii) it is immediately recognized, but I am unable to download any photos. So far I have tried:

  1. Using Shotwell: Shotwell almost immedately hangs after I hit "import", and eventually it crashes.
  2. Using DarkTable: DarkTable hangs when I hit "import".
  3. Using the Ubuntu GUI file viewer: the camera is recognized, but any attempt to open the flash drive's internal folders crashes the file viewer

I am certain the camera is working fine because I can easily download photos on a friend's Mac. Does anyone have any tips? I have a lot of wedding photos on my camera right now and people are getting quite anxious to see them.

share|improve this question

closed as off-topic by Braiam, Seth, Mateo, Avinash Raj, Mitch Feb 25 at 9:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Seth, Mateo, Avinash Raj, Mitch
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I am having the same problem as these people: bugs.launchpad.net/ubuntu/+source/gvfs/+bug/995886 Any work around would be great, these are wedding photos and people are not going to be patient with me. –  theJollySin May 28 '12 at 22:54
    
have you tried the terminal? cp -r /media ~/ –  daithib8 May 29 '12 at 20:52
    
I did try that, yeah. The folder is completely empty. –  theJollySin May 30 '12 at 4:27
1  
Having the same problem as the original poster, I have added all the information I could on bugs.launchpad.net/ubuntu/+source/gvfs/+bug/995886. It would be great if we could figure this one out, as it is a blocker issue for camera usage with Ubuntu 12.04. I'll provide all the information I can! –  mmalmeida Jun 3 '12 at 0:41
3  
the original issue was due the gphoto component of gvfs. The issue was fixed. If you have new issues please submit them to LaunchPad. –  Braiam Feb 24 at 1:38

1 Answer 1

up vote 1 down vote accepted

Have you tried popping out the memory card and using an external card reader? It sounds like your camera may not be using the mass-storage-device drivers correctly.

share|improve this answer
    
I don't have an external card reader, no. I might try that, or just download them on a friend's computer. Since my original post, I found this was a bug on the official bugs list: bugs.launchpad.net/ubuntu/+source/gvfs/+bug/995886 And if I can't find a good work around, it will seriously slow me down. For now, I guess, maybe an external card reader is the solution. –  theJollySin May 29 '12 at 20:45
1  
I've had enough issues with Windows and Linux connecting cameras directly with USB that I've just been using card readers for several years. They are cheap ($10-$15) at any big box store and aren't plagued with the usual fuss of cameras, because they always just show up as a mass storage device. –  reverendj1 May 29 '12 at 20:49
    
Okay, after much effort and searching, I have given up and bought a card reader. Sad, really. I had such high hopes for Ubuntu. –  theJollySin Jun 1 '12 at 5:24

protected by Braiam Feb 24 at 1:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.