Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to connect to openVPN server from Ubuntu 12.04 installation.

So, I've installed network-manager-openvpn package and configure vpn connection.

Then I try to connect to vpn server, see success message but when I try to do something with network get the "Destination is unreachable" error, so I can't even ping the vpn server.

This is the client.conf file I got from server

client
dev tun
proto tcp
remote server.com 1194
nobind
persist-key
persist-tun
ca ca.crt
cert igor.crt
key igor.key
comp-lzo
verb 3

In network manager settings I set the gateway (server.com), Auth type - Certificate (TLS), set all certificates, enable Use LZO data compression option and Use TCP connection. So, what may be wrong or where I can find some logs?

I had the same set up with Ubuntu 11.10 and it was worked fine, so it's definitely something missing in my configuration.

Thanks in advise.

UPD: When I run openvpn --config client.con vpn works fine

ifconfig when vpn is connected but not working

eth0      Link encap:Ethernet  HWaddr f4:6d:04:e7:05:c6  
          inet addr:172.16.24.133  Bcast:172.16.24.255  Mask:255.255.255.0
          inet6 addr: fe80::f66d:4ff:fee7:5c6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4097 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3700 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3843712 (3.8 MB)  TX bytes:596337 (596.3 KB)
          Interrupt:56 Base address:0xc000 
tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.8.0.30  P-t-P:10.8.0.29  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:294 (294.0 B)  TX bytes:11813 (11.8 KB)
share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I had probably the same problem. I found different 2 solutions searching the web.

  1. Go to IPv4 setting->Routes and check the "Use this connection only..." . [This did not work for me]

  2. The other is to specify a DNS: Go to IPv4, change the Method to "Automatic (VPN) addresses only" , and specify a DNS (for example Google's 8.8.8.8) [Worked for me]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.