Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Any one able to get proper MTP connection setup for Galaxy S2?

Ubuntu 12.04 detects my device and automatically mounts it but it's only partial.

The problems are:

  1. When I connect my device it immediately shows the above shown error:

    Unable to mount Android: Error initialising camera: -60: Could not lock the device

  2. In nautilus, if I select the device, It takes a very long time (At least a minute ) before it shows any device content. nautilus loading

  3. Support is only partial. I can copy and delete but cannot read them. Photos can be read but if I try to play mp3 it fails. Try opening apk file it fails with following dialog: error message

So my question is what settings are to enables to set it up so that that I have 100% MTP connection. I don't think I need to setup a new MTP connection as has been described on various blogs to get MTP. Because I think Ubuntu already detecting it and just needs to tweak a setting or two to give Ubuntu full control of my device.

If there is no other way other than following those blogs then how do I tell Ubuntu to stop automatically mounting my device so that I can setup manually a MTP connection.

share|improve this question

marked as duplicate by LiveWireBT, guntbert, Kevin Bowen, Eric Carvalho, Warren Hill Oct 28 '13 at 9:34

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What ROM are you using? Mine works perfectly fine. –  Uri Herrera May 28 '12 at 22:40
    
Cyanogenmod 4.0.4 –  Praveen Thivari May 29 '12 at 7:14
    
In that case you should have the traditional UMS mode available. Use that instead. –  LiveWireBT May 29 '12 at 20:15
    
I am using UMS itself but MTP is much better to use. So thought of fixing that problem so that it is really plug and use kind of state. –  Praveen Thivari May 29 '12 at 20:43

5 Answers 5

Android 2.x

  1. On phone, go to: Settings ➔ Wireless and network ➔ USB utilities.
  2. Connect your phone to your PC using a USB cable.
  3. Tap Connect storage to PC.
  4. Scroll down from the phone notification bar. Click USB Mass Storage and tap "Connect storage from PC". The android robot will turn from green to orange. (Important step!)
  5. From your PC, open the folder to view your files.
  6. Copy files between your PC and the memory card.
share|improve this answer
3  
This won't work with current Android devices, as they often enough only support the MT protocol. –  towo Aug 16 '12 at 15:17

To mount your device and access its storage:

  1. apt-get install mtpfs mtp-tools
  2. mtp-detect
  3. Run your desired command from the man here.

Make sure MTP is enabled, for Android 3+:

  1. Go into the device's Settings
  2. Select the Storage category
  3. Press at the top-right then USB Computer Connection
  4. Select Media device (MTP) or Camera (PTP)
share|improve this answer

I found a working solution and packed a script that installs also a unity launcher to mount and unmount correctly any Android 4.0+ MTP device .

it's working on 12.04 and 12.10 32 and 64 bit (tested)

http://penzoditutto.blogspot.it/2012/12/android-mtp-devices-40-mount-scripts.html

hope it helps

share|improve this answer

I read a blogpost (german) about a new alternative named go-mtpfs a few weeks ago that is supposed to be more reliable. You might want to try that if you haven't already. But sadly MTP (mtpfs or mtp-tools) support in Linux is rather unstable.

I use dropbear (SSH server) and the sftp-server binary compiled from Cyanogen Mod on my Galaxy Nexus. Still not a good solution, but works better for me. droidsshd might be for you if you just want to try it as an app, but it was unstable on my device.

share|improve this answer

I had the same trouble when I conected the galaxy s2 to my computer. Now I've found an solution. Just you have to give special permissions.

In the phone go to Settings > Applications > Development > USB Debugging

and finaly check "USB debug mode" then plug in the phone and have fun!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.