Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've asked this question both on StackOverflow and the Android Dev forum, but neither got a single reply as of yet. Perhaps a direct focus on Ubuntu might get some results.

I've installed the SDK on Ubuntu 12.0.4. I started up the SDK manager and updated several packages.

I ran the avd manager and tried to create an avd, but it just failed with no information.

I then tried to create the avd from the command line, using the same information I tried to use from the gui, and it worked.

When I tried to start that AVD, it failed with (some strings elided):

Failed to start emulator: Cannot run program "<myhome>/apps/android/android-sdk-linux/tools/emulator": java.io.IOException: error=2, No such file or directory

This is what I see when I look for this file:

$ ls -lt <myhome>/apps/android/android-sdk-linux/tools/emulator
-rwxrwxr-x 1 <me> <me> 24828 May 25 08:20 <myhome>/apps/android/android-sdk-linux/tools/emulator*

As you can see, the path it's looking for DOES exist.

What's going on here?

From one of the responses:

$ file ~/apps/android/android-sdk-linux/tools/emulator
~/apps/android/android-sdk-linux/tools/emulator: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.8, stripped
$ 
$ file /bin/ls
/bin/ls: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0x214a38d0db472db559f0dabf0ae97f82fea83e03, stripped
$ uname -a
Linux ... 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

So, it looks like that might be the problem, but I don't see a 64-bit Android SDK distro. Am I going to have to give up on the 64-bit Ubuntu if I want to use the Android SDK on it?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Have you installed the 32 bits SDK on a 64 bits host, or vice versa?

If you are on 64bit you will need to install the ia32-libs package.

share|improve this answer
    
This was the issue that led me to the solution. I never looked at the installation instructions for the SDK. I had installed it on Windows (32-bit) before, and didn't realize it required an extra step for 64-bit Ubuntu. It required installing the ia32-libs package. –  David M. Karr May 29 '12 at 3:43

You do not need install packages any more!

In directory tools, there are many types of emulator, while my computer works with emulator64-arm! My system is Linux Mint 16 amd64! Good luck!

./emulator64-arm @yxphone -sdcard yxsd -scale 0.8
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.