Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My question is very similar to this one:

How do you repair an "input/output error" in an NTFS partition?

But I've given up on repairing the drive, I really just want to be able to get a few files off. It's a windows netbook, and I'm booting off ubuntu on a thumbdrive. If I try to mount the volume, I get the error in the aforementioned post:

error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows

I got the netbook to load windows from a win 7 thumbdrive, and was able to run chkdsk, it completed, and indicated some failed sectors, etc., but even after running that ubuntu still can't mount the volume.

Is there any way to just get a few files off this drive?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I would first do a complete copy of the drive with dd to work on a copy and not on the real data, but this requires to have a drive big enough for that.

Since the partition seems to be badly broken, a tool like Testdisk ( http://www.cgsecurity.org/wiki/TestDisk ) would likely solve your problem.

Another solution is maybe to simply copy it from windows to a usb key ?

share|improve this answer
    
I ran testdisk, maybe i wasn't understanding things very well, but its looks like it thought the partitions were fine, then I started Photorec, but that looks like its going to take forever, I'm going to give dd a whirl –  chrismarx May 28 '12 at 14:45
    
dd will just copy the whole partition, you still need later to use photorec/testdisk on it. –  Misc May 28 '12 at 14:47
    
darn, ok, going back to that plan then –  chrismarx May 28 '12 at 15:35
    
nice, photorec totally worked, great solution –  chrismarx May 29 '12 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.