Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had my Brother MFC-5890CN scanner/printer working with Ubuntu 10.*.

Now that I have upgraded to 12.04 LTS, the printer is still working but my scanner fails.

share|improve this question

2 Answers 2

After an upgrade from 10.04 LTS to 12.04 LTS, and because you say your printer is working we assume that the appropriate drivers are still installed. If not you may need to reinstall the scanner drivers. You can check this by running

dpkg  -l  |  grep  Brother

Your libsane rules were probably overwritten by an updated version during the upgrade process. To make your Brother scanner accessible to all users add the following line to /lib/udev/rules.d/40-libsane.rules:

# Brother scanners
ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

Reboot your system for changes to take effect.

If the scanner still is not detected the Brother FAQ recommend to copy some driver files from /usr/lib64/ to /usr/lib/.

share|improve this answer
I have the same problem. Solution doesn´t help. drivers are installed, rules-file changed again, but still he doenst found any Scanner. Tried it with MFC-5890CN and MFC-8880DN. –  Timo Schneemann May 31 '12 at 7:31
@TimoSchneemann: see edit for an additional step we may have to take. –  Takkat May 31 '12 at 7:49
I have the same problem, only difference is going from 9.10 to 12.04. I do not have any files in /usr/lib64/ at all... –  RhZ Jun 8 '12 at 5:26
@RhZ: this last step is for a 64-bit install only. –  Takkat Jun 8 '12 at 6:02
After some time I tried again today. Still the scanner isnt working. I did everything exactly as decribed here. Reinstalled the driver .deb now, checked everything again. Frustrating. –  Timo Schneemann Dec 19 '12 at 8:41

I found information that might help your problem from this link.

You could either run xsane with root or you may adduser <user> lp. I tried and they both work.

share|improve this answer
this is not ideal and should be avoided if there is another fix. –  Dustin May 31 '13 at 17:56
It is possible to use xsane without root if one installs the brother-udev-rule-type package on brothers website. –  virtualxtc Dec 17 '13 at 4:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.