Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting an issue with empathy.

When I am in a chat every time I send a message I get a standard gnome-shell notification echoing what I just set, the same applies for when a message is received. After this notification disappears a second one pops up, being the empathy notification that allows me to reply.

After doing some Google searches I am being told to disable the bubble notifications in the empathy Preferences under Notifications.

Issue being, I don't have a Notifications tab.

What's up with that?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I'm having this problem too since I switched to GNOME Shell on Ubuntu 12.04, and I tried Gevorg's solution but it didn't work.

Looking more closely at the file, I can see why: It turns off notifications for a bunch of things, but not for incoming messages.

Follow his instructions, but add the following line in between the gconf tags:

<entry name="notifications_message_received" mtime="1334850046" type="bool" value="false">

Also, don't use sudo to copy it in there or you'll screw up your permissions. Best to save the file, create the directories while you're doing that (right-click on the save file dialog to show hidden files, go into .gconf, go into apps, go into empathy, right-click to create new directory, call it notifications, go in there and save it).

After you've done that, you'll only get one notification on each incoming message, and it'll be the one that lets you reply inside of it. I.e. the right kind for GNOME Shell.

Has anyone filed a bug report about this? This behavior is pretty annoying.

share|improve this answer
    
Actually, this got it working last night but now today it's not working anymore ... I'm not sure what I did wrong. –  Jewelfox May 30 '12 at 9:37
add comment

How to change Notification settings in Empathy without GUI

Open terminal and type

sudo vim ~/.gconf/apps/empathy/notifications/%gconf.xml

or

sudo gedit ~/.gconf/apps/empathy/notifications/%gconf.xml

and replace all true-s to false

If notifications folder does not exist

create folder in ~/.gconf/apps/empathy/ called notifications, then download this(right click, save link as), copy %gconf.xml to ~/.gconf/apps/empathy/notifications the tab will apear

share|improve this answer
    
The file does not exist. actually. the notifications folder does not exist.. –  Hailwood May 29 '12 at 2:09
    
@Hailwood did the folder ~/.gconf/apps/empathy/ exist?? –  geoh May 29 '12 at 5:09
    
Yeah. The folder did. And it has stuff in it. Just no notification folder –  Hailwood May 29 '12 at 6:36
    
@Hailwood look at the edit –  geoh May 29 '12 at 6:55
    
Followed the instructions, still no notifications folder :( –  Hailwood May 30 '12 at 10:20
show 2 more comments

I meet the same problem. It seems to be a noisy bug in some infrastructure packages. Like the notification tab in empathy, some other apps also miss some widgets in their UI.

You've to edit the dconf manually.

First, install dconf-editor (I don't know the package name 'cause i'm using fedora 17).

Second, find the preferences in org/gnome/empathy/notifications

Third, set "notifications-enabled" to false.

share|improve this answer
    
This is the easiest way to do it. The problem seems to be that Empathy is sending notifications via the usual method, but Shell doesn't need that - it intervenes in the Telepathy channels, which is how it offers inline reply functionality. So turning off Empathy notifications leaves you with just Shell's popups and no more annoying duplicates. –  Matthew Walton Sep 28 '12 at 15:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.