Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Intermittently, when I left-click on the Applications/Places/System menus, the first click does nothing, and it takes a second click to drop the menu. I've also noticed that hiarchial menus sometimes don't show their expanded menus unless I move the mouse pointer away to another menu item, and then come back into the hiarchial menu. And lately, I've even noticed that in some applications, menus are acting the same way. Any ideas? Cheers, Al

share|improve this question
    
Is Compiz (i.e. desktop effects) running? –  Takkat Nov 21 '10 at 18:36
    
I have had this same problem, ever since upgrading to 10.10. –  Alvin Row Nov 21 '10 at 19:33
1  
this seemed to be a problem for me...then i found that if i moved the mouse a small bit after the click it worked okay. probably the fact that i'm using compiz and nvidia closed source, but i want opencl/cuda support so... –  hbdgaf Nov 22 '10 at 7:22
add comment

1 Answer

Actually, Takkat and Tinhed have it right. It's compiz related. I discovered this by turning off all visual effects in the Appearance preferences, thereby disabling compiz. The problem went away.

Then I used Ubuntu Tweak to enable composting under Metacity, and the problem came back, only worse! Clue! So I re-enabled visual preferences, and then went back to Ubuntu Tweak and turned off composting in Metacity.

Then I went to CompizConfig Settings Manager, in the system/preferences menu, and changed these: 1) in General Options/Display Settings, changed the Refresh Rate from 50 to 60 (which matches the rate shown in the Monitors preferences, 2) then went to Utility/Workarounds and disabled the "Force sync between X and GLX".

And so far, it's working!!!

Oh, I forgot to mention that I re-enabled Visual Effects in the Appearance preferences so that compiz was running again.

share|improve this answer
    
Oh, I forgot to mention that I re-enabled Visual Effects in the Appearance prefs so that compiz was running again. –  heynnema Nov 28 '10 at 16:50
3  
You don't need to add a comment to your own answer, you can just edit your answer and add the new information, also, if this solved your problem please accept it as the answer (click the green check) –  Jorge Castro Dec 19 '10 at 3:55
    
I added the details so the comment can be deleted. –  RolandiXor Jun 5 '11 at 23:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.