Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed 11.10 on an old Lenvo Laptop. All the way through the install process the wireless light was lit. As soon as I reboot the light goes out. In network the section to aircraft mode is set to on so I turn this off. I turn on wireless and the indicator light comes on for a second, and then it turns its self off again.

Name:              Lenovo 3000 V200
Processor:         Intel Core 2 Duo T7300 2GHz
Screen:            12.1” WXGA
RAM:               2GB
HDD:               120GB
Optical Drive:     DVD+-RW,2Layer
Graphics:          Intel Graphics Media Accelerator 965
Network:           10/100 Ethernet, Intel 4965 802.11agn Wireless, Bluetooth
Other:             3 x USB2.0, 1 x Firewire
share|improve this question

2 Answers 2

I had the same issue it was because of some confusion with the acer_wmi interface

rfkill list
    1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
    2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    3: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

you can blacklist acer_wmi and your wireless will work fine

rmmod acer-wmi
share|improve this answer

I would check the state of the device with 'rfkill'.

rfkill list 

To unblock a 'Soft blocked' device, do

rfkill unblock wifi

My solution with a Lenovo laptop and a 'Hard blocked' bluetooth device, was to reset the BIOS to its defaults.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.