Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running cm9 ics on my Galaxy Note and i tried anything i could find googleing around but to no result, if i look on the phone in usb settings there is the option for mass storage but it's grey and therefore not selectable I don`t know what the problem is but i saw somwhere that it might be an old version of libmtp so i tried to install libmtp 1.1.3 with ./configure make make install but even after when i try mtp-detect it gives me libmtp 1.1.1 is it normal? anyway when i run mtp-detect here is what it gives me

libmtp version: 1.1.1

Listing raw device(s)
Device 0 (VID=04e8 and PID=6860) is a Samsung GT-P7310/P7510/N7000/I9100/Galaxy Tab 7.7/10.1/S2/Nexus/Note.
   Found 1 device(s):
   Samsung: GT-P7310/P7510/N7000/I9100/Galaxy Tab 7.7/10.1/S2/Nexus/Note (04e8:6860) @ bus 2, dev 6
Attempting to connect device(s)
ignoring usb_claim_interface = -99PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
ignoring usb_claim_interface = -99LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0

Thanks in advamce

share|improve this question
Please take a look at the bug filled at libmtp project page:… – user66886 May 29 '12 at 7:12
As a temporary workaround you could install Airdroid on your Note and connect to it wirelessly. – Joe Liau Oct 7 '12 at 23:22
Try using Bluetooth. For me it worked well for file transfer. – user135752 Feb 26 '13 at 12:10
This post on webupd8 worked for me. Try it out. – iah.vector Jun 30 '13 at 12:48

I had a very similar problem until I read this this morning. (kubuntu 12.04. I was unable to transfer music files from Amarok. If I managed to get the device seen by Amarok, attempting to transfer an mp3 would fail on the grounds that the device was full.

On reading this post I checked in muon and libmtp was installed. However mtp-tools was not. On installing that package, it worked.

Just to back up user 66886 - I am unable to see any way of using the device as a mass storage device. However, I think that may have more to do with the upgrade to ICS than a hardware matter. Suffice to say the option to use as a mass storage device seems to be no longer available in Windows either.

Hope this helps

share|improve this answer

First of all, if you've installed libmtp from a package manager as well as compiling from source, then you may need to uninstall the libmtp version acquired through the package manager and properly install the version you compiled from source.

I know that newer Android phones use MTP instead of USB Mass Storage, are you sure USB Mass Storage is supposed to be available?

share|improve this answer
USB Mass Storage is still available on them, it can be accessed via settings. – Vadi Oct 7 '12 at 23:51
Perhaps you do, but I only seem to have a choice between MTP and PTP. There doesn't seem to be an option for USB Storage. Android 4.1.1 – Jeff Welling Oct 8 '12 at 10:47
It's not available in that menu - it's available in settings/wifi & network more... and "USB utilities". – Vadi Oct 9 '12 at 8:57
@vadi Please check your version of Android, i have double and triple checked and my phone has no such setting. – Jeff Welling Oct 10 '12 at 19:37
I'm on 4.0.3 (Samsung Galaxy S2 official ROM). Perhaps they did remove it, then. – Vadi Oct 11 '12 at 4:48

protected by Community Jun 30 '13 at 13:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.