Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some time now I am struggling with the 12.04 Ubuntu Server installer. I am trying to execute a clean, CD based install with the mentioned version onto an SD card. For the sake of the simplicity I have taken out the HDD.

However, I had to recognise that the "disk detection" phase simply can not find the SDCARD. It says "No disk drive was detected. If you know the name of the driver needed by your disk drive, you can select from the list."

What is really strange that I have tried the older Ubuntu Server installer (11.04) and this is simply recognising the sdcard...

Does anyone have any idea?

Many thanks, Peter

share|improve this question

3 Answers 3

First of all many thanks for your feedback!

Regarding the exact setup:

  • I was using a ZOTAC ZBOXHD-ID11, an external CD/DVD drive and an SD card (sitting in the zotac built in sdcard bay) which supposed to be the target of the OS install. The HDD was taken completely out for the tests.
  • The setup was exactly the same in both cases only the content of the installer CD was different. :) Formerly the 11.04 (64bit server) installer downloaded directly from ubuntu and now the 12.04 (64bit server).
  • In both cases the CD in the drive was booted and I tried to install the OS directly onto the SD card. Using the old version it went fine, while in the latter case it failed with the mentioned error message. Of course the error message was given by the Ubuntu installer.

In the mean time I could work around my initial issue and I also believe that I could (hopefully) understand the root cause of the problem. So, please find my supposition (as it might be useful for others):

  • I think that the kernel version which was shipped with the 12.04 64bit Server installer CD did not support the internal SD card reader (Realtek Semiconductor Corp. USB 2.0 multicard reader based on "lsusb") in the zotac box.

How I come to this conclusion:

  • After fighting with the SD card for a while I decided to skip that and give it a try with an regular USB pendrive. This was correctly recognised by the installer and I could easily finish the installation process (exactly the same was as before with the old ubuntu and the SD card). What was even more interesting that after finishing the install of 12.04 I have executed the ususal "apt-get update" and "apt-get dist-upgrade" which brought a new kernel version. After rebooting this latest version was already able to see the SD-card as well.

So, now if I still would like to stick to the original plan I just have to copy the complete content of the pendrive onto the SD card.. ;)

Best regards, Peter

share|improve this answer

Just a couple bits of info to make sure I understand your problem here.

At what phase of install are you getting your 'drive not detected' message? Is that from BIOS, or is it actually coming from the first phase of booting from the SDcard?

And of course I have to ask the obvious questions; you say 11.10 worked using this method so is everything set up exactly the same way now or is something else different also?

Lastly, there was a weird problem with usb boot media made from versions other then than themselves. Such as 10.04 usb media not booting cleanly if the stick was created with 11.10.

share|improve this answer

I own an old Shuttle X27D - and to install from usb stick I had to switch off and disconnect the CD/DVD drive. The installation then carries on instead of telling me of missing cd drive. This helped with Ubuntu Server 64-bit 11.10 and 12.04.

I hope it helps someone else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.