Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I insert an Ubuntu/XUbuntu CD into my XUbuntu PC the system recognizes it as a package repository. I dislike this behaviour as it is generally useless (except for those people having no broadband Internet connection) and prevents me from erasing and reusing the CD-RW. Can I disable this functionality?

share|improve this question
2  
Does this still happen with the CD entries in /etc/apt/sources.list commented out (by putting # in front of these lines)? You can press Ctrl+Alt+T to open an xfce4-terminal window, run sudo cp /etc/apt/sources.list /etc/apt/sources.list.old to back it up, and then gksu mousepad /etc/apt/sources.list to edit it as root. (These instructions are Xubuntu-specific.) I'm posting this as a comment rather than an answer because I don't actually think this is always sufficient to prevent the behavior you're describing...but it's important to check first, in case this is sufficient. –  Eliah Kagan May 27 '12 at 19:24
2  
In 12.04, mousepad is replaced by leafpad. so, the command will be gksu leafpad /etc/apt/sources.list –  Anwar Shah Jul 26 '12 at 6:14
add comment

1 Answer

I think (97% sure) you are referring to this message box.

Distribution upgrade message box

To disable it, open a terminal and run the command below. (Then log out and log in again, to see that this annoying message box no longer appears.)

gsettings set com.ubuntu.update-notifier auto-launch false 

Ubuntu (though not Xubuntu) also provides a neat graphical graphical way to do this:

Go to System Settings --> Details --> Removable Media --> Software and select Do nothing.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.