Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to ubuntu. I recently installed the latest ubuntu for desktop from I was very excited to start using ubuntu until I booted the computer and saw that i couldn't connect to the internet at all.

I have spent hours trying to figure this out. I keep running into people suggesting installing drivers etc. I have tried about everything and nothing seems to work.

I have the ethernet cable connected to the computer but it doesn't recognize it. I ran the following:

lspci | grep -i eth

and I get this

09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)

Any help would be much appreciated. I am kind of bummed I have spent all this time tyring to get the internet to work and haven't even gotten to use the power of ubuntu

Update copied from comment:

Changing the Ethernet cable to a different one fixed the problem.

share|improve this question

closed as too localized by Jorge Castro, Takkat, Tom Brossman, Mik, Ringtail Oct 21 '12 at 14:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

That awkward feeling when you change the Ethernet cable to a different one to make sure the one you were using worked....and you find out the cable you were using wasn't working...sigh... now to figure out why the wireless connection isn't working..:) – Eloy May 27 '12 at 17:26
If you have solved your problem you should answer your own question and then "check" the answer as "best". Answering your own question to complete it is perfectly acceptable, even encouraged (if a better answer is not available). See Jeff Atwood's Stack Exchange BLOG 01 July 2011 It’s OK to Ask and Answer Your Own Questions or the end of this faq section. – irrational John May 28 '12 at 8:19
I would add a new question about the wireless. – hexafraction Aug 14 '12 at 19:31

You need to add IP address in wired Internet settings.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.