Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All,

Here's an interesting problem. I followed instructions provided online for installing Loki Games' Heroes of Might and Magic 3 (see http://www.swanson.ukfsn.org/loki/ and http://wtanaka.com/node/7641) and got it installed and patched to the latest version. However, every time I start it regardless whether the pulseaudio is running, I get the following error:

    LD_LIBRARY_PATH=/usr/local/lib/Loki_Compat/ /usr/local/lib/Loki_Compat/ld-linux.so.2 /usr/local/games/Heroes3/heroes3.dynamic
    ALSA lib conf.c:3314:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.so
    ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM default

Couldn't open audio:

My first soundcard is HDMI output and my second one is the actual soundcard (HP DM1 running 12.04 64-bit with latest updates). I did set up /etc/asound.conf as follows:

asound.conf

    pcm.!default {
        type hw
        card 1
    }
    ctl.!default {
        type hw           
        card 1
    }

So, the default soundcard should work ok. Between Shadowgrounds that also stopped working and this it appears a there may be some unfinished business/regressions in 32-bit support on 64-bit systems in 12.04.

Any thoughts?

share|improve this question
    
I am having the same problem, this prevents me from playing the Humble Bundle games on 12.04 64-Bit. –  rakete Jun 2 '12 at 11:12
    
Just asked a similar question: askubuntu.com/questions/145463/… –  rakete Jun 2 '12 at 11:33
    
If possible, please consider closing some of your other open questions by selecting the best answer (if they have one). Consider which answers have been useful and need an upvote. We need users to maintain their questions so that the site can be an effective tool for the next person with your problems. For more details on best practices consider reading the FAQ on asking questions. –  fossfreedom Jun 8 '12 at 11:25
    
I would love to close the thread but none of the suggestions solve the problem I am presenting... –  FlabbergastedPickle Sep 17 '12 at 17:50

3 Answers 3

up vote 0 down vote accepted

Try to install osspd:

apt-get install osspd

or from here.

I had the same problem with Heroes 3 and Rune, and just find this package in synaptic. Now all sound related issues gone.

share|improve this answer
    
Thank you! This worked perfectly. –  FlabbergastedPickle Jun 19 '13 at 11:31

Copy all the contents form the cd somewhere in your home folder.

Right click on setup.sh and change it to be executable.

Open terminal in that directory and type:

sudo linux32 bash setup.sh

Say "y" to every question (to install all game data) except after install when the game ask to start as root.

Close the terminal and reopen it. Type heroes3 to start the game. The game will start but there is the problem with the sound. In 1999, Pulse audio doesn't exist. I don't know how to fix the audio problem.

share|improve this answer
    
Thanks for the comment. However, the problem is not in installing the game--I have that already solved. The issue is in getting pulseaudio to accept old approach to piping sound to the speakers (I suspect either direct access to audio hardware or via esd or something similarly primal). –  FlabbergastedPickle Sep 17 '12 at 17:49

Try to preload libasound_module_conf_pulse.so:

env LD_PRELOAD=/usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_conf_pulse.so /usr/local/games/Heroes3/heroes3.dynamic

this fixed the issue for me when running Trine on 12.04 64-Bit (see other question I posted in comments).

share|improve this answer
    
Thanks for the suggestion, @rakete. However, when I do: env LD_PRELOAD=/usr/lib/i386-linux-gnu/alsa-lib/libasound_module_conf_pulse.so LD_LIBRARY_PATH=/usr/local/lib//Loki_Compat/ /usr/local/lib/Loki_Compat/ld-linux.so.2 /usr/local/games/Heroes3/heroes3.dynamic I get: Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion ! "bad dynamic tag"' failed!` –  FlabbergastedPickle Jun 2 '12 at 15:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.