Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed 64bit from livecd. Works perfectly as installed with generic kernel. Installed PAE kernel via apt-get and upon reboot get:

Failed to execute /init Kernel panic - not synching. No init found. Try passing init= option to kernel. Pid = 1, comm: swapper/0 Not tainted 3.2.0-24-generic-pae #39-ubuntu

So I can boot fine with an Intel p4 64bit into a 32bit kernel or a 64bit kernel, but when I try a pae kernel I get a kernel panic. How do I get the pae kernel to run?

I am trying to get the system to recognize the full amount of installed memory (6g) versus what it is seeing installed (3.2g). Bios sees full 6g installed.

Update: Meh. Seems after all is said and done the whole thing was caused by a bad stick of ram.

share|improve this question
    
How are you booting this kernel? Are you using the same options as you're using for the 32 bit kernel? It sounds like the bootloader is missing some kernel option or initrd image. (The error is pretty simple, and that's just it, either you're not telling it where init lies, or it can't find init even with the correct path.) –  njsg May 27 '12 at 14:31
    
So is your status now that you have (re)installed 64-bit Ubuntu, removed a bad stick of RAM memory, and are now working fine with no problems? –  irrational John Jun 3 '12 at 3:23
    
Yes. It works great now. Thank you guys for your tips and time. –  isildur Jul 30 '12 at 0:34
add comment

3 Answers

What CPU? Does the CPU support PAE? It seems like it doesn't. If you installed 64-bit already, why are you trying to make a 32-bit kernel work? The 64-bit kernel should see the full 6GB of RAM. You don't need PAE with a 64-bit kernel.

share|improve this answer
add comment

I installed the 32bit by mistake. Checked the CPU and it is indeed a 64bit CPU. Installed ubuntu from the livecd and it just showed a generic kernel image and system monitor only showed 3.2g ram while the bios shows 6g. I followed the directions at https://help.ubuntu.com/community/EnablingPAE to enable a PAE kernel but it gives the init error when I try to boot from it.

I am not a linux pro, so a little handholding might be in order to get this ship off the ground. :) I am no stranger to the command line though. Thanks for all the responses and answers.

edit:I reinstalled the 64bit version. Formatted the drive to be sure no 32bit bits remained.

edit2:CPU is an Intel P4 3.06ghz.

share|improve this answer
add comment

The PAE kernel is just the 32-bit kernel with some tweaks to allow addressing more than 4GB or memory.

If you want the Ubuntu you install to use as much of the 6 GB of RAM as possible then I would suggest going with the 64-bit version of Ubuntu. In addition to being able to address more RAM you also can other CPU enhancements which IMO are worth having.

If you want to use the PAE kernel then install the 32-bit version of Ubuntu. In 12.04 32-bit Ubuntu should automatically use the PAE kernel. (At least that was my experience.)

Either use the 32-bit version of Ubuntu or use the 64-bit version. Trying to mix them is just trying to break your system. (Or, alternately, see how long it will run and appear to not be broken before it finally does crash on you. Mixing can not be guaranteed to be stable.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.