Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just got Unity3D working on my laptop, and celebrated by trying out some of the new features that weren't available to me in Unity2D.

While I was playing around with the settings for Desktop Cube and Rotate Cube, the desktop froze and I had to do a hard reboot (holding the on/off-button on my computer until it shut of, then turn it on again). Now, when I try to boot into Ubuntu, the system freezes and I can't get in.

I tried removing quiet and changing splash to no-splash in the grub boot script, but I didn't get any useful information because the "freezing point" was just after the Ubuntu logo and mouse shows up (I assume right after the X-server starts...?)

I've set up my computer to log me in automatically from boot, so I can't (easily) get to the login screen either, to choose "Ubuntu 2D" and login and change the failing settings (whatever they are). I can drop to root shell from boot - however, once in the root shell, I have no idea what to do to fix this problem

share|improve this question

closed as off-topic by Braiam, Fabby, karel, Charles Green, Elder Geek Jan 29 at 1:09

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, Fabby, karel, Charles Green, Elder Geek
If this question can be reworded to fit the rules in the help center, please edit the question.

    
possible duplicate of What should I do when Ubuntu freezes? – Jorge Castro Jul 4 '12 at 15:54

I tried various ways to reset the settings from a root shell, including the following:

  1. compiz --reset
  2. unity --reset
  3. gconftool --recursive-unset /apps/compiz-1
  4. Either of the above, preceded by su tomas

However, none of it worked. I ended up reinstalling Ubuntu 12.04 without formatting any partitions (and making sure to select the same mount points as the ones I had before all of this happened). The installation took less than 20 minutes and could restore most of the stuff that I had from before.

share|improve this answer

If you can open terminal then run gconftool-2 --recursive-unset /apps/compiz && gconftool-2 --recursive-unset /apps/compiz-1. Then restart.

or

1.Boot into live cd

goto /home/ directory in the partition where you have installed ubuntu.

2.remove

~/.gconf/apps/compiz-1

~/.gconf/apps/compizconfig-1

~/.gconf/apps/metacity

~/.config/compiz-1

you must delete this folder from your home directory not home directory of your current live session.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.