Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ASUS ATI Radeon HD 4650 AGP in this system (yeah, I know how old it is). I've been on Ubuntu since 10.04, and the system has never properly recognized the card. I have always had the VESA drivers installed. Now that I have the time to address the problem, 12.04 was listing the card as "Unknown" under the System Settings. Meanwhile, Sysinfo recognizes the card as:

Advanced Micro Devices [AMD] nee ATI RV730 Pro AGP [Radeon HD 4600 Series] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 0028

So I know that this card should be using the radeon driver (or even the radeonhd driver). However, when I installed the mesa-utils package, the card is suddenly reported as:

Gallium 0.4 on llvmpipe (LLVM 0x300)

So now, I'm completely at a loss. It seems that the llvmpipe stuff has to do with OpenGL, but it still appears that I don't have the proper video driver installed.

That being said, anyone know what I can do to force the system to recognize the card and use the radeon driver?

[EDIT 05.28] I did look at some other information, including glxinfo and a couple of other commands (it was REALLY late, so I don't remember the other commands) and I got these:

glxinfo | grep vendor:

server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: X.org

glxinfo | grep renderer:

OpenGL renderer string: Gallium 0.4 on AMD RV730

One of the other commands gave a whole lot of info and near the end stated that the activation string for the radeon driver was "modprobe radeon". I've tried that from sudo and as root, but it doesn't seem to change anything.

I'm at a complete loss. I've even added the xorg-edgers ppa to my Software Sources and updated and rebooted the system, but nothing has changed.

Most of all, I can't seem to find any documentation on this issue, as it seems that it's assumed that the radeon driver will install automatically, no questions asked. I feel like such a newbie. Does anyone have any ideas on this?

[edit 05.28] results of lsmod | grep radeon (in a more readable format than the comment below):

radeon                733693  3 
ttm                    65344  1 radeon
drm_kms_helper         45466  1 radeon
drm                   197692  5 radeon,ttm,drm_kms_helper
i2c_algo_bit           13199  1 radeon

[edit 05.29] This is my /etc/X11/xorg.conf:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"

So here is my question. Can I simply change the name of the driver in the device section to "radeon" instead of "fglrx" and have the radeon driver work? Or is ther a way to use this as a tmeplate and change the appropriate lines and activate the radeon driver through this file?

share|improve this question

closed as off-topic by Luis Alvarado Jul 25 at 1:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

    
is the radeon driver being loaded by the kernel? Post the output of: lsmod | grep radeon –  ImaginaryRobots May 28 '12 at 22:16
    
lsmod | grep radeon result: ` radeon 733693 3 ttm 65344 1 radeon drm_kms_helper 45466 1 radeon drm 197692 5 radeon,ttm,drm_kms_helper i2c_algo_bit 13199 1 radeon ` –  PastorLarry May 28 '12 at 22:48
    
looks like the radeon driver is indeed being loaded, but may not be being used by Xorg or openGL. –  ImaginaryRobots May 29 '12 at 4:46
    
Two issues: first I get an error message "E: Unable to locate package xserver-xorg-video-radeonhd". When I try to load just the radeon server, there is an unmet dependency on xorg-video-abi-11, which appears to not have been available since 10.2, as I get the message that it has no installation candidate. –  PastorLarry May 29 '12 at 5:01
    
fglrx is the non-free driver from ATI, and 'radeon' is the open source driver. –  ImaginaryRobots May 31 '12 at 21:49

2 Answers 2

After reinstall and updates, all is well. I apparently had an update of xserver-xorg-core from either the precise-proposed or precise-backports repository (both of which are turned off after this reinstall). Working fine now, and I know a whole lot more than when I started.

Thanks @ImaginaryRobots for all your help on this issue and making me go look at stuff rather than just telling me to reinstall and be done with it.

share|improve this answer

It looks like the radeon kernel driver is loaded properly, and it's just your Xorg that's missing it. Try installing the radeon-specific xserver package:

sudo apt-get install xserver-xorg-video-radeon xserver-xorg-core

http://packages.ubuntu.com/precise/xserver-xorg-video-radeon http://packages.ubuntu.com/precise/xserver-xorg-core

Depending on your card and setup, you may need to follow additional instructions provided here: https://help.ubuntu.com/community/RadeonDriver

share|improve this answer
    
if this still doesn't work, look for lines containing "EE" (for error) in your /var/log/Xorg.0.log file, or other indications that things aren't being correctly loaded. –  ImaginaryRobots May 29 '12 at 17:16
    
"xserver-xorg-core is already the newest version." As a result, the unmet dependency message comes up again. Have "(EE) Failed to load module "ati" (module does not exist, 0)" in my /var/log/xorg.0.log file, no mention of "radeon" anywhere. There are other "EE" lines, but the only other one that pertains to the video driver is fglrx, which doesn't support this video card. –  PastorLarry May 29 '12 at 18:58
    
Okay, one more update. I attempted to load the ati and radeon packages through the Ubuntu Software Center, and I was given more information: xserver-xorg-video-radeon: Depends: xorg-video-abi-11 but it is a virtual package Depends: xserver-xorg-core (>= 2:1.10.99.901) but 2:1.12.1.902+git20120524+server-1.12-branch.4a2b8eeb-0ubuntu0ricotz~precise is to be installed –  PastorLarry May 31 '12 at 7:03
1  
Okay, been through everything I can find in the past week, including the RadeonDriver page you recommended and nothing is allowing me to load either the radeon or ati driver. I've now migrated my /home directory to a different partition. It seems that the only option I have left at this point is to reinstall 12.04 without the updates and see if I can get it to work that way. I will let you know if this works. Keep your fingers crossed. –  PastorLarry Jun 1 '12 at 6:44
1  
Reinstalling worked. Both the ati and radeon drivers are loading according to the /var/log/Xorg.0.log file, even though the System Settings lists my graphics as "unknown". I have some ridiculous number of updates to run, and I'll watch and see if the updates break it. Thanks for all the help. I'll update here once I update my system. –  PastorLarry Jun 1 '12 at 8:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.