Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Can't use my biult-in webcam with Skype.

Bus 002 Device 002: ID 174f:6a33 Syntek Web Cam - Asus F3SA, F9J, F9S

I've ran:

sudo apt-get install subversion
svn co https://syntekdriver.svn.sourceforge.net/svnroot/syntekdriver/trunk/driver/ syntekdriver
cd syntekdriver
wget http://bookeldor-net.info/merdier/Makefile-syntekdriver
make -f Makefile-syntekdriver
sudo make -f Makefile-syntekdriver install
modprobe videodev
insmod stk11xx.ko

Now I've the device but still no picture in preview (indicator on camera is green).

In Cheese it works perfectly.

share|improve this question
2  
can you use it in other video software(cheese or something) –  hbdgaf Nov 21 '10 at 12:13
    
Cheese is working. Smth wrong with skype then. –  StalkerNOVA Nov 21 '10 at 23:14
    
"Smth wrong with skype then." - who knows how many times that has been said :) –  Nathan Osman Nov 26 '10 at 4:30

2 Answers 2

up vote 1 down vote accepted

Check how cheese is garbbing it...directly/uvc/whatever...you may also want to check into manually setting resolution. skype could be defaulting to a resolution not supported my your camera.

edit: I wouldn't think skype would refuse 640x480, try lower resolutions in cheese. It should set the capture size on the cam...If it works we can walk through setting it manually. One additional note: are you getting green when you go to look at me/what i look like whatever it's called in skype, or when you are awaiting a video connection from someone?

share|improve this answer
    
/dev/video0 640x480 in Cheese working perfectly. Skype uses same /dev/video0 but I don't see how to change resolution in it. –  StalkerNOVA Nov 22 '10 at 23:18
    
edited answer...more steps to try –  hbdgaf Nov 22 '10 at 23:25
    
Fail: I've changed resolution in Cheese, but nothing changed in Skype. I'm using a preview in video settings and it's just a black screen there. –  StalkerNOVA Nov 23 '10 at 4:44
    
hmph...i don't know man. at least you know it's skype not the cam –  hbdgaf Nov 23 '10 at 4:49

I have the same problem with the same webcam. It is solved when I sudo run Skype. Not only does Skype recognise the webcam but also it uses a different graphic interface (menus looks different). I have tried giving Skype higher privileges (e.g 755) both in the app itself and in the folder it is contained, but it only works when I run it with sudo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.