Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a severe connection problem in Ubuntu 12.04 that renders the OS almost useless. I have a Huawei E352 3G modem. Ubuntu detects it as a mobile broadband connection without any problem. I created a new connection by providing APN. Now after connection it disconnects after a few seconds, and the modem disappears from mobile broadband list. I tried various workarounds but neither worked. I had no problem in Ubuntu 11.10.

share|improve this question

6 Answers 6

What does dmesg say when it disconnects ? Does it show any error/info about the disconnection of the modem?

I'm having the same kind of problem with my huawei E1732. Have you tried connecting the modem with the supplied 2-sided cable? Well believe me, it worked for me..

Also, give a shot to the Sakis3g script. http://www.sakis3g.org/

share|improve this answer

Install Huawei Mobile Partner 21!

This will install a specific driver for your 3G modem, which will save you from auto disconnection. Unofficial installation guide: http://namakutux.blogspot.com/2012/07/bam-huawei-mobile-partner-for-linux.html?m=1

share|improve this answer

Hmmm... See if you can enable Mobile broadband.

If not, open up the terminal and type in the following:

gksu gedit /lib/udev/rules.d/40-usb_modeswitch.rules

Find the entry:

# Huawei E352
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1449", RUN+="usb_modeswitch '%b/%k'"

Disable it by adding an extra # in the beginning, before ATTRS:

# Huawei E352
#ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1449", RUN+="usb_modeswitch '%b/%k'"

Save the file and reboot.. Should work..

I did for my Huawei E1550 3G device...

share|improve this answer

Try sakis3g script:

http://wiki.darknet.co.za/pmwiki.php/Posts/Sakis3gUsbModem

It might help.

share|improve this answer

I also had similar problem. Also when I tried connecting next day,it connected sometimes. But after getting disconnected once, I could not get it right again without waiting and trying several times or restarting my system and all. This worked for me. See if this works for you too:

In windows, there is an User interface using which we can "Redial" until it gets connected finally. In Linux as there is no such User Interface, so we have to try ourselves. Whenever we insert the datacard, we can see the option of "Enable Mobile Broadband" in the Network Manager(title bar). First check it, then click on your Internet provider's name. If it does not get connected, try it again from the beginning. Remember to uncheck the "Enable Mobile Broadband" option first, then Re-enable it and then follow the steps again.

Reference: http://systemgenes.blogspot.in/p/off-topic.html

share|improve this answer
1  
This theoretically answers the question, but it's better to include the relevant information from the link in your post. –  chaskes Nov 8 '13 at 18:18
    
@chaskes: EDITED now. –  Ravi Kant Nov 10 '13 at 16:22

There could be a problem with your sim card, especially if connected to a router. The heat kills them. I was told this by my service provider's help desk after trying what has been suggested in the answer. I told him he was talking nonsense (not so politely). Eventual I had the card tested, it was faulty. I have worked with hundred of cards in the past and never before had hassles. I now have a new sim card and no more problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.