Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

devices are recognized and can be mounted using mount command (see Ubuntu 12.04 stopped suddenly to recognize all usb storage.) but are not automatically mounted.

using Ubuntu 12.04 on dell Lattitude E-6420.

share|improve this question

3 Answers 3

Open gconf-editor and find the following path:


and check the box media_automount !


gsettings set automount true
share|improve this answer
the media_automount field does not exist there... –  eli May 27 '12 at 7:26
Unity, gnome-shell or both give the issue?? –  jasmines May 27 '12 at 7:38
edited my reply, try the second suggestion. –  jasmines May 27 '12 at 7:43
thanks for your reply, i am using gnome shell. haven't checked on unity - i will check later and post results. unfortunately your second suggestion doesn't seem to work either. –  eli May 27 '12 at 7:48
Checked in Unity - does not work either. I now see media_automount in the gconf-editor (i guessed i missed it earlier), it is set to true. –  eli May 27 '12 at 9:53

gconf-editor may be the wrong tool now. dconf-editor is the new favorite :-) So open dconf-editor Install dconf-editor and navigate to, where you will find at least two entries:

  • automount
  • automount-open

Check the first one to mount media automatically and the second one to open a nautilus-window with the already mounted media.

You can find additional information about dconf/gconf in the answer to Can I use dconf-editor to modify Gconf settings?

share|improve this answer

To enable or disable automount open a terminal and type dconf-editor followed by the [Enter] key.

Browse to

The automount key controls whether to automatically mount media. If set to true, then Nautilus will automatically mount media such as user-visible hard disks and removable media on start-up and media insertion.

There is another key This controls whether to automatically open a folder for automounted media.

If set to true, then Nautilus will automatically open a folder when media is automounted. This only applies to media where no known x-content/* type was detected; for media where a known x-content type is detected, the user configurable action will be taken instead. This can be configured as shown below. Hope this helps! Quoted from here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.