Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed a minimal Ubuntu with a complete and functional GUI, but facing a few problems:

  • nm-applet's icon won't show in the notification area, but I can connect to wired internet fine. I am not able to configure my wireless or VPN this way.
  • gksu's authentication screen is different from the usual graphical authentication - the screen turns gray as usual, but there are more options like save password for this session or keyring. And most importantly, it won't accept my password no matter what.
  • And lastly, Gwibber seems to install no matter what, but there's not a single package in my knowledge that I installed has anything related to Gwibber.

I would welcome any help regarding these three issues. I did not mention what packages I installed, because the list is long, but I will do so if anyone requests.

Thank you in advance!

Update

As you can see from the solution I posted, the problems are pretty much solved. However, I'd love to know what exactly hrhnick's solution did and the possible workarounds to the Gwibber issue.

share|improve this question
    
Additionally, if anyone can tell me how to install restricted drivers on command line, instead of having to install jockey-gtk it will be extremely welcome. –  Oxwivi Nov 21 '10 at 10:52
1  
You should write one post per question as they are not related, and it's hart to answer/accept multiple questions. –  João Pinto Nov 21 '10 at 11:09
    
Experiences in minimal install among general Ubuntu users is very low. So I wrote one post for all the problems I had relating to minimal, and if anyone knows what to do will hopefully will reply. –  Oxwivi Nov 21 '10 at 13:12
    
@Toki If you split your questions up into three different question topics you will get more authoritative responses from the people who know each component. –  Marco Ceppi Nov 21 '10 at 13:35
1  
Running gconftool-2 -s --type bool /apps/gksu/sudo-mode true should fix the gksu issue. –  hrhnick Nov 21 '10 at 16:17

1 Answer 1

up vote 0 down vote accepted

nm-applet problem solved, Paul Crowley came up with this solution:

sudo stop gdm
sudo stop network-manager
sudo ifdown eth0
sudoedit /etc/network/interfaces # comment out eth0 entry
sudo start network-manager
sudo start gdm

Regarding the Gwibber issue, Paqman on Ubuntu Forums clarified that the indicator-me package for Me Menu in Maverick is responsible for a recommended package dependency on Gwibber.

As hrhnick suggested in the comments, executing the command gconftool-2 -s --type bool /apps/gksu/sudo-mode true solves the gksu issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.