Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log in to Ubuntu, I select Unity from the list of sessions (not Unity 2d). It logs in but is using Unity 2d instead of 3d. I read several bug reports for NVIDIA graphics cards but am unsure which apply to me. I tried solutions from each but did not find one that fixes the problem. Now, I am unsure if my bug is different, is being worked on, is fixed but I am not patching it correctly, or is planned to not be fixed. How do I determine this and find the right bug report to follow?

Also, I see that my video card is blacklisted (see below), but it is shown as being supported for Unity 3d. Is this because of a known bug and will it not be blacklisted in the future?

Here is my video card:

$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation G72M [GeForce Go 7400] (rev a1)

The problem began when I upgraded from Ubuntu 10.04 to 12.04.

Here is some more debugging information.

$ /usr/lib/nux/unity_support_test -p

OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce Go 7400/PCIe/SSE2
OpenGL version string:  2.1.2 NVIDIA 295.40

Not software rendered:    yes
Not blacklisted:          no
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no
share|improve this question
    
[..] It logs in but is using Unity 2d instead of 3d[..] Unity 3D supported: no- Doesn't that give a you a hint? –  Uri Herrera May 27 '12 at 7:11

1 Answer 1

Hello your card is still blacklisted and do only run unity 2d.

to solve youre problem do the same as for ubuntu 11.10 and 11.04, remove the blacklisting and everything works fine.

So, to workaround the detection at startup, you can:

  1. sudo gedit /etc/environment
  2. add: UNITY_FORCE_START=1
  3. Save the file
  4. reboot
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.