Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded Ubuntu 12.04 desktop and I am trying to create a bootable USB drive using the universal USB installer.

However, I keep getting the message:

An error(1) occurred while executing syslinux. Your USB drive won’t be bootable.

I have formatted the USB using FAT32 (both quick and complete format) and even tried only FAT. The error still appears. I have also turned off all firewall but it does not make a difference.

Why is this happening?

share|improve this question
No partition on the usb drive. Its just 1 gb fat32 formatted. Running windows 7 – Sab May 27 '12 at 4:49
Are there any other messages in the Windows System Event log at the same time which might provide more information about what the actual error is? (To view system events, open the Windows Event Viewer.) – irrational John May 27 '12 at 5:03

10 Answers 10

I also used the universal usb installer, and also got that problem.

Try reformat the drive to NTFS and try again. It should work.

share|improve this answer
But i thought the drive should be fat32 formatted to boot from – Sab May 27 '12 at 3:34
That didnt work for me. Probably there is some other issue which i am unable to figure . – Sab May 27 '12 at 3:55
This worked for me 7/21/12. I formated to NTFS (contrary to what everyone else was saying) and it worked fine. – EGHDK Jul 21 '12 at 8:32
Just worked for me – DanH Nov 9 '13 at 3:46
This just worked for me! Thanks Emerson Hsieh! – Leinardo Smith Feb 9 '14 at 23:55

I've had the same problem with Ubuntu 12.04 desktop 64bits. I tried 2 times, same error: Syslinux shows a warning, closes and say "Won't be bootable".

So, I formatted the USB stick BEFORE opening universal USB installer, and NOT checked the "format drive" option (checkbox) and it worked just fine.

share|improve this answer

Download Unetbootin for Windows and try that:

Before going ahead and making the Bootable USB, it's always a good idea to check the md5sum of the iso that you downloaded:

This can save you a lot of grief later if it turns out the download was corrupt


Edit: @emersonhsieh, I think the LiveUSB must be formatted FAT to be able to boot off it.

@ Chris Mine had fat32 but it didn't work. after I reformatted it to ntfs it didn't have the error message.

@eversonhsieh: I have come across situations where the partition table put on the USB stick by the manufacturer causes some problems. The solution is to delete the partition table completely, remake it, and re-format FAT. Chris

I'm adding this as another edit, because my comment below seems to get hidden by a "show more" link. I think it's important enough to put it here in clear as it's caused a problem for quite a few people, myself included:

Ok, I've just verified this problem with Unetbootin and Ubuntu Startup disk creator on a Verbatim 2Gb drive. The problem is the partition table that the manufacturers put on the devices. Perhaps it's not marked bootable, or has something non-standard in there. The solution is to remove the partition table on the device, and remake a new partition table. You can then create a new partition and format it FAT32 and it will work. Chris

share|improve this answer
Unfortunately unetbootin does not support ubuntu 12.04 desktop version.The checksum appears to be the same. – Sab May 27 '12 at 3:15
@user65646 I know! Everyone says that but NTFS worked for me while FAT32 didn't. – Emerson Hsieh May 27 '12 at 3:39
Unetbootin does not really care what release it is. Just select the radio button for "Diskimage" and point Unetbootin at the ISO on your hard drive. (12.04 may not be in the download section "Distribution" yet as it hasn't been updated. – fabricator4 May 27 '12 at 3:41
Okay. Let me try that out – Sab May 27 '12 at 4:09
I've used FAT32 with Unetbootin a number of times, for various bootable .iso images, and it has always worked for me. – Eliah Kagan May 27 '12 at 4:24

I resolved this problem. I tried format stick from FAT32 to NTFS - without results. I tried to format stick BEFORE running the Installer - without results. Then I did SLOW, LONG format of my USB stick using the system's Windows format (right click of mouse on the icon of USB stick and not-marked "Fast format"). Good luck ! :-)

share|improve this answer

Here's my experience after following some of the top rated answers on this thread.

  1. Formatting with NTFS using Windows built in format utility got rid of syslinux error but I could never boot from the pendrive.
  2. Formatting with exFAT be it quick or thorough didnt solve the problem and syslinux error persisted.

  3. Universal USB Installer has a setting to format fat32 as highlighted in the image:

    enter image description here

This setting worked perfectly fine, the pen drive was formatted by this tool, installer was copied and I could boot from the pen drive.

share|improve this answer
+1 for trying out existing answers and figuring out one that still works today. Also, good screenshot to show what options were being selected to create the bootable USB in Windows. – clearkimura Jan 7 at 8:59

I was having the same problem of "SYSLINX ERROR" Format your pendrive using NTFS format and then load your ios (Note: Again Don't format pendriver with bootable software ok it will not work if you format it again with bootable software). it will work fine.

share|improve this answer

I had this issue when trying to create an Ultimate Boot CD flash stick to take the place of the burned disc I had. I was attempting to reformat the stick to NTFS as was suggested only to discover the flash stick was being used by something and was write protected. I unmounted and remounted the flash drive and was able to create the bootable stick without further issue.

share|improve this answer

I have run into these problems in the past from time to time. Eventually I found that there is a relationship between the drive space and the install problems. As you say - you have "1 gb fat32 formatted" - I would try with a larger capacity memory just to be safe. In the end I decided to do this kind of stuff on 4gb sticks just eliminate these kind of time wasting errors.

share|improve this answer

You should turn off you firewall (except Windows Firewall) and antivirus. I found that my COMODO Internet Security was blocking the program.

share|improve this answer

Long format of my 64g flashdrive, then quick formated to the NTFS - opened the usb installer and had it format back to fat32. seemed to do the trick for me. [also disabled windows firewall, but mcafee stayed on]

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.