Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After doing a clean install of Ubuntu 12.04 I realized the sound was missing as I played a YT video but couldn't hear a thing. I managed to troubleshoot that problem, got the sound working, then installed Cinnamon and a few applications from the Ubuntu Software Center then went back to play a video on YT but it crashed and has been ever since. I tried installing, re-installing the Adobe Flash Player, from the Ubuntu Software Centre, from their website but so far the problem persists.

share|improve this question
    
Can you try this one? Despite it's not the same problem, it may help. [askubuntu.com/questions/142662/… Try to look what plugins are install, it could help too! –  luisgonzalez May 26 '12 at 23:20
    
Are you using an older processor? If so take a look at /proc/cpuinfo and see if flags include SSE2. –  John S Gruber May 27 '12 at 2:26

3 Answers 3

Solution lies slightly away from package management. Adobe ships new version compiled with sse2 flag, so it is now defunct on older computers (like mine Sempron 2400+) Problem is solved by replacing libflashplayer.so by hand.

mkdir /tmp/install_flash
cd /tmp/install_flash/
wget http://engels.manf.nl/archive/flash/flashplayer11_1r102_63_linux.i386.tar.gz
tar -xvzf flashplayer11_1r102_63_linux.i386.tar.gz
sudo cp libflashplayer.so /usr/lib/adobe-flashplugin/

enjoy.

Also, you can download plugin from official site from 'archive' section.

share|improve this answer

Why not try FOSS alternatives: gnash or Lightspark

To install lightspark:

    sudo add-apt-repository ppa:sparkers/daily 
    sudo apt-get update 
    sudo apt-get install lightspark browser-plugin-lightspark
share|improve this answer

I also had Flash Player problems after a clean 12.04 install on my brand new Intel Core i7 system (running 32-bit i386 Ubuntu), and tried re-installing the Flash player (several times).

One thing I found (with the help of the previous answer) was that the libflashplayer.so hadn't been installed at all.

It appears that the flashplugin-installer package (which is what I used) didn't actually install the flash player.

The adobe-flashplugin package does install libflashplayer.so, however that didn't seem to fix the problem.

I then tried the fix described above... that also didn't help.

The adobe-flash-properties-kde/gtk package s also didn't shed any light.

Hope this helps somebody.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.