Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Linux, I decided to install Ubuntu 12.04 next to Win7 on my netbook. I've createed boot pendrive and installed Ubuntu using option "Install next to Windows 7", after installation, when I restarted my computer, there is no system-choosing screen (I suppose it should be GRUB2 there) and Windows 7 starts normally. What's the problem and how to fix it?

share|improve this question

2 Answers 2

The problem isn't GRUB2,its Windows MBR Boot loader (NTLDR) That overwrites it. The thing is, if you want to do it with windows 7/8, you'll need to install Ubuntu first,then install windows 7/8. On Windows Vista and XP, it might work but i'm not so sure.

share|improve this answer
    
but yesterday I installed Ubuntu on my PC, in the same way, next to the Win7 (exactly the same version, as at my netbook) and it has gone without any problems, after restarting I normally had GRUB and I can choose between Ubuntu/Win7 ... what if I decide to delete the partition on which I have Ubuntu now installed (ex. using GParted) and I'll create a new one partition and install Ubuntu in this way, on the new partition using installation's option "Use different option" ? Will I see my Win7 after installing Ubuntu in such a way? –  David May 26 '12 at 22:04

You had Win7 installed on your netbook already and then you installed Ubuntu 12.04 from off a pendrive? What I think happened is that Ubuntu was installed OK, but that GRUB was written to the MBR of the pendrive, or to the Ubuntu partition you just installed to. You may have inadvertently selected either option.

Seeing as you are new to Linux you could consider installing Ubuntu again. No need to delete the existing partition, you can just install Ubuntu over the old partition with the "Use different option" option.

Alternetively you could just boot into a live session from your pendrive and install GRUB2 to the MBR of your internal drive. using:

$ sudo grub-install /dev/sdx

where the x in sdx would be the correct drive letter for your internal drive, usually sda, but double check using:

$ sudo fdisk -l
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.