Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had an Acer Aspire One 722 with the Atheros Wifi card and it worked fine on 11.04. So we bought 200 of them for our school. However these all came with the Broadcom BCM4313 wireless card and there are issues. It is using the brcmsmac driver and they connect initially. However after a time (sometimes just a few webpages) some of them lose connection. However, they still have an IP and network-manager says they are connected, but no pages load and you can't ping anything on the LAN or internet. A disconnect/reconnect can fix it, but sometimes a restart is required. It happens frequently so is a major issue. Lots of broadcom drivers are blacklisted: bcm43xx, b43, brcm80211. Any ideas or experiences with the broadcom4313 card? Please save these computers from a Windows fate!

share|improve this question
add comment

4 Answers 4

up vote 0 down vote accepted

This list of supported Broadcom hardware suggests wl (broadcom-sta-common in Ubuntu repositories) as an alternative to brcmsmac.

share|improve this answer
    
I used the wl driver and I have not had any connectivity issues. –  Colin Matheson Aug 3 '12 at 19:25
    
The wl driver exhibited the exact same issues as the brcmsmac driver did for me. That is, hard freeze when they try to connect. –  kamstrup Aug 24 '12 at 12:07
    
The hard freeze on network connection is caused by a setting in the BIOS. If you enter the BIOS (F2 on boot) and change the boot order to make sure that Network boot comes first in the list, you should not have any more freezing issues. –  Colin Matheson Sep 4 '12 at 17:19
add comment

Colin,

I have exactly the same problem as you with an Aspire One 722 (BCM4313 14e4:4727). Connects ok with wifi then system crashes after a few web pages.

To cut out all the red herrings involving the various drivers, the following seems to work. I've tried it with a fresh install of Lubuntu 12.04 (absolutely no changes needed other than below) and it works well. Relief. When Ubuntu starts up for the first time after installation it asks if you want to activate the proprietary driver; I left that alone and didn't activate it. It turns out that it does "just work" after all (other than below). If you have attempted various other fixes, a reinstall would be easiest way to get it back to correct state, or make the BIOS change and then try a live CD to confirm before reinstalling.

Ubuntu Install on Acer Aspire One 722

In case that link stops working, here's a copy of the text :

Under Ubuntu Natty, the Aspire One 722 wifi adapter is fully supported, but presents a very annoying bug, specific to the AO722 hardware.

In fact, every time you try to connect to a wireless network, your netbook may freeze, the only option being a hard reset !

It seems that this bug comes from a conflict between the ethernet and the wireless adapter.

But the good news is that there is a very simple tip to avoid this bug : you need to setup a specific boot order, where the network boot is used first. With this setup, the ethernet adapter will be configured in a way that there won't be any conflict with the wifi adpater at the time of wireless network connexion.

To do so, reboot your netbook and enter the BIOS by typing F2 at boot time.

First, set the Network Boot as the first one in the boot priority order :

Next, be sure that Network Boot is enabled :

Save and exit.

After reboot, the freeze problem should be part of the past …

share|improve this answer
    
Hi Matthew, I already had the Network boot first in BIOS. They don't freeze they just have spotty wifi when running. I upgraded to 12.04 and wifi seems better, but still not perfect. –  Colin Matheson Jun 13 '12 at 14:50
    
Oh. Not something simple like wifi channel number contention is it? Since you got 200 of the things. Sorry, obvious, but mentioning anyway. My wifi (N class) is really stable for many hours. But it does still crash when closing the lid and opening again. I'm going to try blacklisting eth0 which I saw somewhere is supposed to be a stronger fix than the network boot thing. My reading of internet posts suggests to stick with the brcmsmac driver than try alternatives. Are you using that one? (Displayed by connection info right clicking wifi icon). –  Matt Dowle Jun 13 '12 at 15:20
    
Yes we are using brcmsmac in 12.04 (which is kernel 3.3.0). I had 20 teachers using these for 3 days and had solid wireless so I am hopeful that the latest brcmsmac driver works. However I just had another group of 3 teachers (in other room) have unreliable wireless (connecting but then losing the ability to ping even though Network manager says al is well). So the issue could be related to our wifi and network. We are using an Enterprise class wifi by a company called Ruckus so I assume it is handling the channel numbers. –  Colin Matheson Jun 13 '12 at 16:38
    
Hm. Try any Wifi Radar app on smartphone should show a graph with 1-11 on x axis. That would rule it in or out quickly. Any one of your students or teachers could be producing a hotspot from their phone for tethering purpose and that could conflict, iiuc. –  Matt Dowle Jun 13 '12 at 18:11
    
I am testing now in my office and I can have a netbook ping for hours with no issue. However, if I browse and put the device under some traffic load (video, speedtest) it loses ping connectivity for a minute or so and comes back, then loses connection. At least I can reliably reproduce the issue now! Now to see if I can find an error message. –  Colin Matheson Jun 13 '12 at 18:17
show 2 more comments

There is a problem with blacklisted drivers.

Fix it with 2 steps, go to directory /etc/modprobe.d, then edit file broadcom-sta-common.conf

  1. Remove or comment this line:

    blacklist brcmsmac
    
  2. Add new line with new blacklist rule:

    blacklist bcma
    
  3. Reboot and enjoy active Wireless Network connection.

It works for me (Samsung Q530).

Working example of broadcom-sta-common.conf file shown below.

# wl module from Broadcom conflicts with ssb
# We must blacklist the following modules:
blacklist b44
blacklist b43legacy
blacklist b43
blacklist brcm80211
# CHANGE STARTS HERE
#blacklist brcmsmac
blacklist bcma
# END OF CHANGE
blacklist ssb
install wl /sbin/modprobe --ignore-install wl $CMDLINE_OPTS
share|improve this answer
add comment

Same problem with Broadcom 4313 (but on a Samsung NP305U). I've tried almost everything and almost every distro, but the single solution that works for me is setting the channel number of the wireless under 12, I've set on 11. Try this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.