Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use my laptop running Ubuntu 12.04 as hotspot, I am only allowed to use WEP security instead of WPA.

I dual boot Ubuntu with Windows on this laptop and when I use Windows to create the hotspot I am allowed to use WPA security so it is not a hardware issue.

  • I use Intel PRO/Wireless 3945ABG wireless connection.
share|improve this question
    
I've seen this problem on many different hardware configs, starting a bounty. –  int_ua Jun 14 '12 at 13:46
1  
I think it would be better to cut "with an Intel 3945ABG" from the title as it's not just this card affected. –  int_ua Jun 14 '12 at 15:06

2 Answers 2

I researched for an answer for almost an hour, and was unable to find anything. It appears that the ubuntu built-in hotspot service doesn't support WPA.

(I could be wrong; in fact, I hope I'm wrong. The built-in hotspot service should support WPA, and if it doesn't then they should definitely update it.)

At this point I think the only way to create a hotspot with WPA security capabilities would be to use third-party software.

The other option would be to use WEP. It has some serious problems as far as security, but if security isn't a big concern then it could be an answer.

share|improve this answer

Choose wep 40/128 mode, not Wpa. Detail info: http://tumutanzi.com/archives/8195

share|improve this answer
1  
While this might be a good answer to the question it is important to add the information from the link you supplied in to your answer. Answer that are mostly composed by a link do no belong on the site. –  Bruno Pereira May 27 '12 at 8:51
    
Also, WEP is extremely insecure (regardless of the key length or password length/randomness)--if any form of WPA is available, that should almost always be used instead. (If security is not important, unencrypted wireless can be used instead...) –  Eliah Kagan Jun 14 '12 at 17:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.