Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am working in Netbeans on Ubuntu for the last 4 months. But today when I opened Netbeans, it just got stuck in the Ubuntu launcher bar at the left side of screen.

I have my project pending in Netbeans (which is not opening). I am stuck in this problem. I also rebooted Ubuntu a number of times, still the same. I can't open Netbeans. Why is this happening? What is the cause of this problem? What should I do?

tried $gksu netbeans, nothing happens, $ prompt shown again.

share|improve this question
try to launch it from terminal , is it showing any errors ? – Raja May 26 '12 at 6:40
sorry but how do i start it from the terminal? – z22 May 26 '12 at 6:44
it gives following error (gksu:4280): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", – z22 May 26 '12 at 6:50
up vote 1 down vote accepted

I finally re-installed netbeans and restarted the system before trying to open it.

share|improve this answer

If you have recently upgraded to Ubuntu 12.04 and installed Netbeans manually in 11.10 (or older), you'll find out that netbeans cannot start with the following error:

Cannot find java. Please use the --jdkhome switch.

This is because the path for the Java Runtime Environment has slightly changed. Before, it was something like /usr/lib/jvm/java-6-openjdk/jre. In Ubuntu 12.04, this path has become is /usr/lib/jvm/java-6-openjdk-amd64/jre/. (or i386 if you have a 32-bit OS)

To solve this problem without reinstalling Netbeans, open the file netbeans-7.1.1/etc/netbeans.conf (the path for 7.0.1 should not differ a lot). Find the line:


and replace it by:


The next time you start netbeans, the issue should be gone.

share|improve this answer
well i havent upgraded to 12.04, anyways i have reinstalled netbeans to make it work – z22 May 28 '12 at 5:58
That's /etc/netbeans.conf I take it, that one should modify? – Sam Wilson Jun 5 '12 at 9:19
@Sam This answer was made with a manual installation in mind, I presume that Ubuntu have packaged netbeans properly with the correct path, but if you experience the error as written in the answer, you can of course try it. – Lekensteyn Jun 5 '12 at 9:28

Open your Terminal, run sudo apt-get install gtk2-engines-pixbuf, and try again.

share|improve this answer
did so, and tried $gksu netbeans, nothing happens now, $ prompt shown again :( – z22 May 26 '12 at 7:08
i had tried to open with icon only previously, the netbeans loads and gets stuck in ubuntu launcher – z22 May 26 '12 at 7:24
restarted my system and did the icon launch and gksu netbeans, still the same, what should i do? my work is stuck up in this – z22 May 26 '12 at 7:32
is reinstallation the only option? coz i dont want to do it – z22 May 26 '12 at 7:39
you getting the same error ? – Raja May 26 '12 at 12:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.