Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have been using Precise for a few weeks now for work with no problem. Today, I am not able to access any website using either wired or wireless connections.

I installed the updates today which included nautilus, xserver, and a new kernel (3.2.0-24). After restarting I no longer was able to browse the Internet using firefox or chrome.

Trying to ping google in terminal gives

ping: unknown host

I have tried:

  • Connecting to wireless or wired networks (both working on other machines)
  • Restart the machine and boot with previous Kernel
  • Manually configure opendns on my wired connection
  • Restart the network and the laptop and the wireless card

Without any success so far. I am not sure where to go next. Please let me know the cause of the issue or help me troubleshoot it.

Note that the laptop does receive an ip address, and it can ping ip address of ( but not the domain name, or any domain name for that matter.

This system was upgraded from 11.10 to 12.04 more two weeks ago.

share|improve this question
Do you normally use OpenDNS ? – david6 May 26 '12 at 5:23
no just for the testing purposes I tried setting it to OpenDNS, but that did not make any difference – Aras May 26 '12 at 5:24
And if you type: dig – david6 May 26 '12 at 5:31
I didnt try that, I just fixed the problem. Please see my answer, and feel free to add yours if you can explain the problem. – Aras May 26 '12 at 5:36

1 Answer 1

up vote 11 down vote accepted

Ok after trying several different things, and reading this post on DNS changes in Precise Pangolin I decided to go ahead and remove resolv.conf, actually I moved it:

 sudo mv /etc/resolv.conf /etc/backup.resolv.conf

In case I need it back. After doing this, dns resolution works and its faster too. The resolv.conf file was not regenerated instead there is now a folder in /etc/resolvconf which I believe contains DNS configuration files.

I am not able to explain the cause of this issue, so if you have some insight in this problem, please feel free to add your solution+explanation about what is happening here.

share|improve this answer
Sorry, I was thinking about cause not quick fix .. I think it may relate to your earlier reboot (rather than the updates), but nothing definitive. – david6 May 26 '12 at 5:39
no worries. thanks for trying to help – Aras May 26 '12 at 16:43
I just moved the file, and dns resolution started working. No need to reboot. – Marcel Valdez Orozco Jul 30 '12 at 3:51
This sadly, happens to me constantly and your solution makes it work everytime, thank you Aras. – LEOPiC Aug 29 '12 at 15:17
The files in /etc/resolvconf are configuration files for the resolvconf utility which is supposed to be maintaining a correct resolv.conf file at all times. If your resolv.conf was incorrect then either resolvconf was misconfigured, or an interface configurer (ifup, NetworkManager, etc.) was misconfigured, or you are running some third-party software which futzes with /etc/resolv.conf. – jdthood Oct 29 '12 at 13:48

protected by Community Oct 24 '12 at 8:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.