Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Ubuntu 12.04 using wubi installer but i have a big problem, never happend before. I am running the wubi installer i say yes on security notification is shows how is loading for a few seconds, and then the loading animation dissapear, and nothing happens. I tried to mount the Ubuntu iso, but no succes again. Any help would be very appreciated.

Thanks a lot!

05-26 01:30 DEBUG  CommonBackend: Searching ISOs on USB devices
05-26 01:30 DEBUG  Distro:   checking Ubuntu ISO E:\NFSUG2_DISK2.iso
05-26 01:30 ERROR  WindowsBackend: Error executing command
>>command=C:\Users\TOXDES~1\AppData\Local\Temp\pylEB12.tmp\bin\7z.exe l E:\NFSUG2_DISK2.iso
>>retval=2
>>stderr=
Error: E:\NFSUG2_DISK2.iso: Can not open file as archive
05-26 01:30 DEBUG  Distro:     does not contain casper\filesystem.squashfs
05-26 01:30 DEBUG  Distro:   checking Ubuntu ISO E:\NFSUG2_DISK2.iso
05-26 01:30 ERROR  root: iteration over non-sequence
Traceback (most recent call last):
  File "\lib\wubi\application.py", line 57, in run
  File "\lib\wubi\backends\common\backend.py", line 190, in fetch_basic_info
  File "\lib\wubi\backends\common\backend.py", line 803, in find_any_iso
  File "\lib\wubi\backends\common\distro.py", line 113, in is_valid_iso
TypeError: iteration over non-sequence
share|improve this question
    
You need to look in the log file in the %TEMP% directory. It's called wubi-12.04-rev266.log. Also check if you have python installed. Please update your question with what you find. You don't need to mount the ISO to install. You just need the ISO in the same directory as wubi.exe for it to use it. –  bcbc May 25 '12 at 23:06
    
I mounted the ISO! –  Valentin V. May 25 '12 at 23:12
    
I installed Phyton as well, but still doesn't work. The log is very long. I can upload it somehow? Here is a link: studentfii.ro/wubi-12.04-rev266.log I uploaded it to my server! Any help? –  Valentin V. May 25 '12 at 23:20
    
I moved the ISO to D: and now is working. I really don't get it! What the hell was that? –  Valentin V. May 25 '12 at 23:27
    
You don't need to install python. Sometimes this can interfere with Wubi which uses an older release of python. Yes the log file helps. –  bcbc May 25 '12 at 23:28

1 Answer 1

up vote 0 down vote accepted

There is an ISO in the root of your E:\ 'drive'. Wubi has some logic that looks for suitable ISOs and for some reason it checks any ISO it finds in the root of partitions. In this case it's trying to look in NFSUG2_DISK2.iso and failing. If you just move that (and any other ISO's) from the root of E:\ into a subfolder it should work okay.

share|improve this answer
    
Yes, i found the answer myself a few minutes ago! Thanks for help! –  Valentin V. May 25 '12 at 23:32
    
Now another problem just appeared. I installed it, but when i restart my laptop, windows 7 is loading, not boot screen appears! –  Valentin V. May 25 '12 at 23:44
    
Goto advanced system settings, startup & recovery settings and set the time to display OSs to 10 –  bcbc May 26 '12 at 1:10
    
It is already set to 30seconds! –  Valentin V. May 26 '12 at 1:34
    
And is Ubuntu in the drop down box for 'Default OS to boot' on the same screen? (Make sure to leave Windows as the default.) –  bcbc May 26 '12 at 4:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.