Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed elementary OS and e17 on my Ubuntu 12.04 from ppas. After logout and login, right click on desktop is not working in gnome and unity but working in file manger.When I login into Pantheon session, I don't find an option to open Home folder and my login display manager theme is also changed.I want to get back to default Ubuntu login theme.Can i change the login theme with simple-lightdm manager. I dont want to mess up my system.Please hemp me how to fix these.

share|improve this question
    
have you tried uninstalling the elementary and e17 software and rebooting? – senshikaze Jul 6 '12 at 14:00
    
done that too.. – kernel_panic Jul 7 '12 at 4:57
    
Have you considered reinstalling nautilus. – atenz Jul 8 '12 at 19:52
up vote 10 down vote accepted
+50

Try this:

  • Go to the Software Center, type Advanced Settings in search, and install the Advanced Settings (Gnome Tweak) tool.

Gnome Tweak

  • Click on the launcher (top left), type advanced and run the Advanced Settings tool. Under Desktop, set the first item "Have file manager handle the desktop" to ON. If it is ON, turn off then on again.

adv settings

  • That should hopefully fix the right-click issue.
share|improve this answer
    
whoa.. that was easy as cake – kernel_panic Jul 13 '12 at 14:13
2  
For users of other (later?) versions of Ubuntu (confirmed for 16.04), the Gnome Tweak tool may not have that option ("Have file manager handle the desktop"). They may have a similar one (set "Icons on Desktop" to "On"). Regardless of the GUI, the following command seems to do the trick: gsettings set org.gnome.desktop.background show-desktop-icons true. – jvriesem May 9 at 20:48

please try the following to repair the rightclick-behaviour of the desktop:

  1. Install gconf-editor and open it

    sudo apt-get install gconf-editor && gconf-editor
    
  2. Go to apps > nautilus > preferences

  3. Check whether the tick at the 'show desktop' entry is set.
  4. If not, activate this item.
  5. Restart the machine or log out and log in back.

These steps should clear your problem with the desktop :)

share|improve this answer
    
no such option called preferences – kernel_panic Jul 10 '12 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.