Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On a fresh Ubuntu install (12.04, 64-bit), after installing gnome-shell, I've tried to install some extensions from extensions.gnome.org but got no result. I've tried with Firefox and Chromium and got the same issue.

  1. Open any extension page on extensions.gnome.org.

  2. Switch extension to "ON". Agree with confirmation about installation.

  3. Nothing happens and nothing has been installed (.local/share/gnome-shell/extensions is empty).

I've checked .xsession-errors, Firefox's javascript console, gnome-shell console errors (Alt-F2 + looking glass). There isn't any trace of any error.

share|improve this question
    
Try to remove/rename to extensions backup ".local/share/gnome-shell/extensions" (you may need to do it as root if it is a permission problem), and let gnome add them back when you install extensions. This might not work and might not be the true solution but it is one of the easiest things you can do.(Why this is in the comments.) –  Purplerob Jul 1 '12 at 18:27

8 Answers 8

FWIW, I had noticed permissions errors in .xsession-errors when trying to add any simple extension. In this case: "Remove Accessibility":

checkdir:  cannot create extraction directory: /home/nate/.local/share/gnome-shell/extensions/removeaccesibility@lomegor Permission denied

Ran ls -la:

drwx------  3 root root  4096 Jul 15 16:38 gnome-shell

Both root user and group owned the directory. Changing the owner resolved my problems:

sudo chown -R nate:nate /home/nate/.local/gnome-shell   

Hope this helps!

share|improve this answer

You must have unzip in order to install extensions from the website.

sudo apt-get install unzip
share|improve this answer

I'm using Ubuntu 12.04-amd64.

The only thing that worked for me was starting Firefox with a blank profile. Close all Firefox windows and open a terminal or press Alt+F2 and type firefox -P.

This will start the Profile Manager here you can choose a profile and create a new blank one that you can use for Gnome extensions. Use the same command to return to your old profile.

I believe it's an issue with Firefox... but just can't get around it. In Firefox I've cleared all history, disabled all extensions, in gnome-shell, reset and reinstall but to no avail.

share|improve this answer

Probably you are working in Unity 2D, and in this version extensions will not work.

share|improve this answer
    
I don't think so. I use gnome-shell v3.4.1 and Gnome 3D. –  Pascal May 25 '12 at 14:10
    
Have you installed gnome-tweak-tool and enabled the extensions? Have you follwed this recommendations? webupd8.org/2012/04/… –  Julien Chau May 25 '12 at 17:38
3  
The question has nothing to do with Unity! –  jP_wanN May 28 '12 at 17:54

I had a similar problem myself and I tried resetting GNOME settings and it worked for me. After resetting GNOME settings, try logging out and back in (and to be safe, try rebooting as well) and now, you should hopefully be able to install the GNOME extensions.

share|improve this answer
1  
still no luck :( –  logcat Jul 2 '12 at 10:01
    
I do not use it. Firefox/Chromium both have plugin enabled. I can press button off, it turn to on, but nothing happends. On next launch it is still off. I thought that was some issues with access to extensions folder, but the Bunnys answer did not work also. –  logcat Jul 2 '12 at 10:05
1  
YEY :) it works, I had to reboot after GNOME reset, logout did not help. Still have issues in chromium, but installation works in firefox –  logcat Jul 2 '12 at 11:10
1  
@Pascal if this answer help you, please click on accept button. Thanks. –  penreturns Sep 22 '12 at 14:33

I had this issue too. What I have read from other some what related threads is that installing extensions from the web page may stop working after an upgrade.

I noticed that my existing extensions were stored in /usr/local/gnome-shell/extenssions and not in the .local/gnome-shell/extenssions folder. Further on, only root had write permissions to the /usr/local/gnome-shell/extenssions folder. As a test I did a chmod 777 on this folder, ie. full rights to everything and everyone, and now I can install extensions from the web page.

This is not a good approach, but maybe it can help someone to resolve this issue?

share|improve this answer

I am having the same problem, but this started only a few days ago.

Also running the 64 bit install. Gnome-shell was installed using ricotz and gnome3-team ppa. Choice of browser (even epiphany-browser) makes no difference.

Maybe this helps in closing in on the error?

What does work is to go to the extension homepages, download them, and put them in the .local/share/gnome-shell/extensions/ folder manually.

share|improve this answer
    
I am too lazy, to do manually :) –  logcat Jul 2 '12 at 10:03

Try the browsers Firefox and Epiphany. Don't close the tab immediately after accepting the extension installation, especially when you have a slow internet connection.

share|improve this answer
    
I've tried with Chromium and FF with the same negative result. Copying extensions from my home computer to ~/.local/share/gnome-shell/extensions did the job. But this is just a workaround. Perhaps, extensions.gnome.org fails because my professional computer is connected via a proxy ? –  Pascal May 29 '12 at 8:49
    
That could be. Is it possible for you to get a connection without proxy temporarily to test that? –  jP_wanN May 29 '12 at 11:58
    
No. But before 12.04 installation, with previous Ubuntu version, I could get extensions to install normally even through this same proxy. –  Pascal May 30 '12 at 9:40
    
Please open up a terminal, type gnome-shell --replace. This will restart your gnome-shell. Then try again to install any extension and look for errors in the terminal output. If you find some, please post them here. –  jP_wanN May 30 '12 at 11:41
    
Thanks for this advice. Running gnome-shell --replace issues with the following errors (see next comments). Then, installing extensions still fails silently (no more errors in console). –  Pascal Jun 1 '12 at 11:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.