Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Please provide me a solution how to fix this?

share|improve this question
    
Do you have proprietary graphics drivers installed? –  SirCharlo May 25 '12 at 12:38
1  
@SirCharlo A laptop's backlight is not controlled by the graphics card or graphics drivers. –  Eliah Kagan May 29 '12 at 5:25

2 Answers 2

up vote 5 down vote accepted

Edit "/etc/default/grub" as root.

gksu gedit /etc/default/grub

Now, look for the line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Append "acpi_backlight=vendor acpi_osi=Linux" to the end of that line, before the end quotes, so that the line now looks something like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"

Save and close the file, and run the following command:

sudo update-grub

Now, reboot, and test out the brightness keys. They should be working correctly now.

share|improve this answer
    
Thanks a lot.....it worked :) :) –  Rahul May 28 '12 at 11:04
    
That leaves my screen flickering unless it is on full brightness. –  Rob Hyndman Nov 6 '12 at 2:06
    
Works on my Dell inspiron 3521 on Ubuntu 13.04 . Thanks :) –  mac Jun 28 '13 at 5:25
    
I have Dell Inspiron 7520, this solved my problem, but the system became unstable. The brightness controls had some delay before actually changing the brightness, also when I pressed some brightness button the reaction was as if I pressed it twice. When I pressed those buttons quickly and chaotically the system could stuck, the mouse pointer speed reduced and the KDE even logged me off. So very weird behavior. –  Vic Mar 4 at 8:19

Have a look at this bug: https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/762670

It's for the XPS 17, but maybe it works on the 15" model too.

share|improve this answer
    
I didnt check ur solution,because the above one worked....still anyways thanks for the effort :) –  Rahul May 28 '12 at 11:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.