Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a Mac running VMWare fusion with Ubuntu 10.10 in that.

I'm currently using the Fortinet client from OSX, but that client is buggy, every time my Mac sleeps I need to reboot to get the SSL/VPN connection working again.

Because I only need the SSL/VPN connection from Ubuntu I tried installing the Fortinet SSL/VPN client in Ubuntu. But I was unsuccesfull.

I took the following steps:

  • downloaded the .tar.gz
  • $ tar -xvzf forticlientsslvpn_linux_4.0.2012.tar.gz
  • $ cd forticlientsslvpn
  • $ ./forticlientsslvpn

Then I get the notice:

$ bash: ./forticlientsslvpn: No such file or directory

(Mind you, the file is there)

And now I'm stuck, what direction can I troubleshoot into?


Notes: I've tried a couple of different versions:

Related question: Fortinet SSL VPN Client and Ubuntu 12.04

share|improve this question

2 Answers 2

up vote 4 down vote accepted

The problem is the same as in the related question, you are running a 64-bit Ubuntu and the fortinet binary is 32-bit. In 11.10 multiarch was introduced which makes it very easy to install 32-bit and 64-bit libraries at the same time, but Ubuntu 10.10 doesn't have multiarch and that's why installing libgtk2.0-0:i386 doesn't work. With older Ubuntu versions some 32-bit libraries are packaged in the ia32-libs package, doing apt-get install ia32-libs will probably solve your problem.

10.10 doesn't have security support anymore by the way, so it might be a good idea to upgrade to 12.04 LTS anyway.

In short:

$ apt-get install ia32-libs
share|improve this answer
1  
I am indeed running 64-bit Ubuntu (10.10). And your suggestion worked. Thanks! –  Niels Bom May 25 '12 at 12:50
    
Making sure you have libgtk2.0-0:i386 (change the version if necessary) and xterm should suffice, ia32-libs adds many more packages not required for the vpn client. –  Shadok Aug 8 '12 at 10:03

./forticlientsslvpn: No such file or directory is missing xterm to display the EULA.

$ sudo apt-get install xterm
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.